external firewire 400 hard failing to mount.

Discussion in 'Mac Accessories' started by bay2sacto, Dec 18, 2008.

  1. bay2sacto macrumors member

    Joined:
    Nov 6, 2008
    #1
    my friend of mine has a external Seagate 500gb firewire 400 drive. It is used for storing audio for his production studio and so has critical data on it. I was transfering some programs to him and plugged it into my Late 08 macbook pro. Everything went ok. The power cable came slightly loose which cause the lovely 'you failed to eject disc properly' error. It then would not mount on my macbook or his G5 (single 2ghz). We tried three different cables. Tried to see if Disk Utility would see it, nope. His other firewire drive mounts fine on both machines as does mine. The Seagate drive can be heard spinning up when the power is turned on. Seems to be a dead Firewire interface on the drive enclosure itself as nothing will mount when using the drive to daisy chain. I was thinking of opening the enclosure and installing the drive as a standard sata internal to get at the data. Warranty doesn't matter just the data.

    Any suggestions?
     
  2. bay2sacto thread starter macrumors member

    Joined:
    Nov 6, 2008
    #2
    Solution Found

    Hello all!

    The problem ended up being the firewire interface hardware on the external drive. My friend had the Seagate FreeAgent Pro 500GB drive which has a external power button and two swappable "modules". One for Firewire 400 and another for USB 2. He had lost the USB one and had to go and buy a replacement. When he plugged in his drive with the USB interface installed the drive worked as expected. He backed up all the data from the drive just in case. The salesman at the store were he got the replacement said there was a known issue with the drives interface failing.
     

Share This Page