External firewire drive has become read-only

Discussion in 'iMac' started by HogHunter, Dec 20, 2008.

  1. HogHunter macrumors newbie

    Dec 20, 2008
    I have an iMac with OS X Leopard and I installed a USB and a Firewire external drive. For a while they both worked fine. Then Like a fool I tried to fix the fact that they are both name My Book. After several attempt to find a place where I can rename the volume, I gave up. However, somehow and I don't recall how, (I am a new Mac user) I lost the firewire drive. I rebooted, went into disk utility and made sure I had access to it and it came back. I really wish I could recall what happened. I didn't pay attention because I thought I was fine. Well now a few days later I realize that one drive appears as a shared folder and the other one doesn't. The firewire one does. I also cannot access the root of the drive to add folders or files. In fact, I think the whole drive appears as a read only device to me now.

    Is there a way I can fix this without reformatting?

    I ran diskutil info and here are the results:

    Device Identifier: disk2s10
    Device Node: /dev/disk2s10
    Part Of Whole: disk2
    Device / Media Name: Untitled

    Volume Name: My Book
    Mount Point: /Volumes/My Book 1
    File System: HFS+
    Owners: Enabled

    Partition Type: Apple_HFS
    Bootable: Not bootable
    Media Type: Generic
    Protocol: FireWire
    SMART Status: Not Supported
    Volume UUID: 59A1BA49-8FB0-3BB3-8677-26F47F782004

    Total Size: 931.4 Gi (1000069726208 B) (1953261184 512-byte blocks)
    Free Space: 407.0 Gi (436981256192 B) (853479016 512-byte blocks)

    Read Only: Yes
    Ejectable: Yes
    Whole: No
    Internal: No
  2. HogHunter thread starter macrumors newbie

    Dec 20, 2008
    I resolved the problem by unmounting the volume and mounting it again. Then I was able to change the read-only attributes to read-write.

Share This Page