external firewire drives not mounting

Discussion in 'Mac Accessories' started by lefleur, Mar 26, 2010.

  1. lefleur macrumors newbie

    Mar 26, 2010
    forgive me if this is a common question, i did do a search and found some similar questions, but none that were providing a good solution...

    I have had 2 Western digital Mybook studio 1TB external drives connected by daisy chain to one another via firewire 800 for a long time and it was working fine until today....now suddenly neither of the drives can mount/be recognized by my Imac 2.8 Ghz Intel core 2 duo 24" running OSX 10.5.8. I have tried firewire 400 and 800 on both drives, tried disconnecting everything, restarting/rebooting, resetting PRAM, verify disk, repair permissions, different cords....nothing works. USB portable drive is still recognized fine---must be a firewire thing? Any advice appreciated and welcomed, I am at my wits end as these drives contain my last 3 years of photography and design work and i now can't access anything. HELP!

    thanks in advance for any help,
  2. jpyc7 macrumors 6502

    Mar 8, 2009
    Denver, CO
    I would imagine that one of 3 HW components has failed (not including the cables), although there's a chance more than one component failed.

    If C, D1, and D2 represent the computer and the two disk drives, then you could try several combinations methodically. However, if you have a friend with a Mac (with Firewire), I would try that first to rule out your iMac as the point of failure.

    So combinations would be:
    C + D1
    If that fails:
    C + D2
    If that fails:
    C2 + D2 or C2 + D1
    If the second computer fails for both disks, then it would really seem to indicate that your disk drives aren't working. Still, it is probably just the firewire interface, which means you might be able to recover the info by taking apart and putting in a new enclosure.

    Other combinations are:
    C + D2 + D1
    C + D1 + D2
    etc. I would write up a little table so that you can take notes on results. It'll be helpful if you have to take it to a shop and a tech asks you questions of what you have tried.

    Also, I'm assuming one or both of these drives has your internal HD backup. Otherwise, I would've suggested using TimeMachine to go back to earlier software in case of a system software issue.

    One other thing to rule out a failure is to get another Firewire HD (that is known to work) and attach it to your iMac. Call that D3. If that works, then you know your iMac Firewire is okay. Basically, you're going to have to work through enough logical combinations to find the failure point.
  3. Fishrrman macrumors G5


    Feb 20, 2009
    Try this:
    - Disconnect the drives
    - Boot up
    - Open Apple System Profiler
    - Does the iMac show a Firewire bus as "being there"? (even with nothing attached to it). It should indicate that there is Firewire "present" (again, with nothing attached).
    - Quit System Profiler

    - Connect ONE of the drives
    - Do you hear the drive mechanism "spin up" inside the enclosure?
    - Relaunch System Profiler.
    - Check the Firewire info again.
    - It should now indicate the "presence" of the external device. Has anything changed?

    If NOTHING HAS CHANGED, looks like the internal firewire bus isn't recognizing the drive (assuming the drive has spun up).

    I'm guessing you tried both of the following procedures already, "by the numbers", is that correct?

    1. Shut down the computer.
    2. Disconnect all devices and all other cables, except the keyboard and mouse cable(s).
    3. Disconnect the computer from the power outlet and wait for 3 to 5 minutes.
    4. Plug the computer back in and turn it on.
    5. Reconnect the device(s) (one at a time if there is more than one) and test. Test with each port if you have more than one."

    Try resetting something called nvram:
    "Resetting PRAM and NVRAM
    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys."

    If you get this far and nothing has worked, I think the next thing to do would be to try connecting the drives to ANOTHER Mac and see if they mount there.

    If they do, your firewire port may be either temporarily or permanently broken/disabled (I've heard of cases where after a while, they mysteriously "reactivate" themselves).

    If you come to that conclusion, don't despair. You can still "get at" your data if the drive mechanisms themselves are good (they probably are).

    Going further....

    If the drives can be mounted on another Mac - but not on YOUR iMac - the solution is to buy one or more external drives and "copy the files over" and then go to another connection method on your iMac (I'd suggest USB).

    For copying them over, I'd suggest one of these:

    Get one or two 1tb SATA "bare drives" to use with it (my recommendation is for Seagate drives).

    Then take everything to the "working Mac" and use CarbonCopyCloner (free) to "do the dupes".

    You can now use the SATA dock and your bare drives on the iMac.

    There's another way, BUT IT INVOLVES OPENING THE WESTERN DIGITAL DRIVES THAT YOU NOW HAVE (but aren't working in their enclosures).

    I'm going to _guess_ that the two "MyBook" drives use SATA drives inside their enclosures.

    If this is the case, you could just break the seals on the enclosures, take out the drives, and use them directly with the SATA docking station in the link above. Of course, this will void whatever warranty is left on them. But bear in mind that if you sent the drives back to WD for a warranty replacement, they MIGHT send you back "empty" drives - that is to say, any data on those drives would be gone.

    It's a Hobson's choice: either break the seals, pull the drives out, void the warranty, and save your data - OR - send the drives back and risk losing your data. Your choice.

    Do the two procedures above to attempt to "re-activate" the misbehaving firewire port (if, indeed, it is "misbehaving")
    Take the two firewire drives to another Mac and try them there, to see if they work/don't work properly on a different Mac. If they "mount up", it's a BIG relief!
    Buy a USB connection solution and a couple more drives, and use another Mac to "copy your data over". Then try connecting to YOUR iMac via USB.
    Buy a USB connection solution, break open the WD enclosures, and try your bare drives with a USB connection method.

    Good luck!

Share This Page