External Hard Disk no Longer Visible - Terminal Help

Discussion in 'macOS' started by pibulus, Nov 16, 2009.

  1. pibulus macrumors newbie

    Joined:
    Nov 16, 2009
    #1
    Hi guys, i have a WD 320 gig hard drive that for some reason has stopped appearing on my desktop, i have already checked it visible on the view options but it appears nowhere, System profiler lists it, and it can be seen in Disk Utility, yet i have no access, it seems it wont mount..

    Now, in Disk Utility the hard drive is listed .. 320.0 Gig WD MY Book ES Media,
    it is mounted, can be verified, and repaired and is fine.

    Below that is the part im after, named "Travieso" its the volume i want to open, same drive, it is not mounted and will not mount, however disk persmission, verify and repair are all fine, the buttons are available and all successful.

    Ive read there are some terminal commands i can use to make it accessible to me again yet i can not understand them entirely.

    Under system profiler the disk is listed as -

    My Book ES:

    Capacity: 320.07 GB (320,072,933,376 bytes)
    Removable Media: Yes
    Detachable Drive: Yes
    BSD Name: disk2
    Product ID: 0x0906
    Vendor ID: 0x1058 (Western Digital Technologies, Inc.)
    Version: 0.12
    Serial Number: 57442D574341505A30363235343635
    Speed: Up to 480 Mb/sec
    Manufacturer: Western Digital
    Location ID: 0xfd100000
    Current Available (mA): 500
    Current Required (mA): 0
    Partition Map Type: APM (Apple Partition Map)
    S.M.A.R.T. status: Not Supported
    Volumes:
    Travieso:
    Capacity: 319.94 GB (319,938,674,688 bytes)
    Writable: Yes
    File System: Journaled HFS+
    BSD Name: disk2s3

    Can someone please help with this issue?
     
  2. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #2
    Go into Disk Utility, highlight the volume, and click the Mount button.

    Also, you can't repair permissions without the volume mounted.
     
  3. pibulus thread starter macrumors newbie

    Joined:
    Nov 16, 2009
    #3
    oh ive tried this but it wont allow me to mount the volume! it will however allow me to repair and verify it (both which check out ok), this is whats causing my confusion :(
     
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    Have you tried powering the external drive up before booting the Mac?
     
  5. pibulus thread starter macrumors newbie

    Joined:
    Nov 16, 2009
    #5
    i have, im using data rescue and it can load and rescue everything just fine.. however i really wish it would show up, everything is fine except it doesnt show!
     
  6. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #6
    What kind of ports are available on the drive, USB, Firewire, eSata? Which are you using? Have you tried a different cable? Have you tried it with a different Mac? Is the firmware up-to-date on the drive?
     

Share This Page