external hard drive blues

Discussion in 'Mac Basics and Help' started by curlyshirley, Feb 26, 2008.

  1. curlyshirley macrumors newbie

    Joined:
    Feb 26, 2008
    #1
    Hello everybody,
    I just bought an iMac and a new SimpleTech external drive for backup, but I can't access it. I've tried erasing it and initializing it but I keep getting the message:
    Disk erase failed: could not unmount disk.
    Also, I have a LaCie Big disk external drive, it works fine with my pc, but is read only on my mac. Any suggestions to fix these hard drive blues?
    Thanks heaps!
     
  2. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #2
    Hi!

    Your Lacie disk is probably formatted with the NTFS file system. This is the Windows file system and your Mac can only read it, but not write to it.
    However, there is help. Install the MacFUSE system. This is only the basis for "new file systems" on your Mac. After that, get and install the NTFS-3G file system from here.
    Doing so, you should be able to read and write to NTFS hard disks.

    As for the SimpleTech disk, have you tried to Verify/Repair the disk in Disk Utility?

    Hope this was helpful.

    /Rupert
     

Share This Page