External Hard drive causes Mac to freeze/hang

Discussion in 'macOS' started by pakmacman, May 31, 2009.

  1. pakmacman macrumors newbie

    Joined:
    May 31, 2009
    #1
    I bought a western digital passport hard drive last week. everything was working fine until yesterday. when trying to copy iMovie events to the drive, it hung, and iMovie crashed. Since that time, everytime I try to mount the drive, my finder hangs.

    I cannot eject the drive properly. I cannot access any old files. I can continue to use other applications, including flock, or tweetie, etc. but can't do anything with the drive.

    I have tried searching the forums, (i'm not an advanced user). I have tried using disk utility, and it says;

    'The disk “Murtaza Malik HD” could not be unmounted'

    When I try to eject it says the drive is in use, and cannot be ejected.

    I was using the drive with time machine. I disabled that, and now time machine also hangs when i try to access it.

    Any help would be greatly appreciated. Please keep it basic! lol I don't want to ruin my mac! Thanks,
     
  2. kjmira macrumors newbie

    Joined:
    Jun 10, 2010
    #2
    i seem to be having the same issue. did you ever get this resolved?
     
  3. durija macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #3
    You might (but probably won't) have better luck, if you run disk utility while booting off your OS X installation disk (assuming you didn't do it that way already).
     

Share This Page