External hard drive corrupt/unrecognised help?

Discussion in 'Mac Accessories' started by therzbm, Mar 22, 2011.

  1. therzbm macrumors newbie

    Mar 22, 2011
    I've got a WD passport drive that I formatted for HFS+ or whatever it is and used it on my macbook pro. whilst copying files from it to an ipod whilst time machine backed up it decided to disconnect itself for no reason and then ruin itself and not be recognised at all by my mac anymore. it spins up etc light flashes but it does nothing and nothing shows up on my mac.

    ive managed to get all the files off it using HFSExplorer on my pc (but the drive is not properly recognised by my pc and does the 'found new hardware' whenever it is plugged in) so the drive hasnt died. I can't think of a way reformat it to get it working again. How can I reformat this drive using my PC or mac and free software, dont want to have to shell out for a HFS reader thingy.

  2. MacForScience macrumors 6502


    Sep 7, 2010
    So windows doesn't let you reformat it to a FAT volume?

    Did you open disk utility to see if the drive appear there on your mac?

  3. therzbm thread starter macrumors newbie

    Mar 22, 2011
    i checked with disc utility on my mac and nothing came up. no matter what i tried my mac would not recognise or interact with the drive in anyway, the drive would just spin up and the light flash as if it was constantly searching it. when plugged into my pc the drive gets detected but i assume due to it being formatted to HFS it wont appear under explorer (ie 'my computer') and the only way to access it is by running HFSExplorer, scanning for the drive and then i can access the drive and all the files on it through HFSExplorer. as far as I know HFSExplorer can't format the drive, and i cant think of a way to format the drive on my pc without it being connected and recognised by windows as a hard drive. at the moment windows understands that something has been connected and asks to search for drivers for it, but can't recognise it as a hard drive.

    the drive definitely works as i have extracted all the files off it to my pc and they work, so I cant see why my mac has a problem with it. whilst it was plugged in i knocked the cable (nowhere near knocking it out, just tapped it) during a time machine back up and an ipod synching and thats when it obviously went mad and got corrupted. it notified my to 'eject before disconnecting' which confused me as i hadnt touched the drive or the cable. perhaps i should just RMA it? WD will replace it right (its 6 months old like my mac).

  4. skorpien macrumors 68020

    Jan 14, 2008
    Have you tried formatting it through the Disk Management in Windows? Right click My Computer, select Manage, and under Storage there should be Disk Management. Then you can see if the drive is listed as a volume and you should be able to format it through Disk Management.
  5. therzbm thread starter macrumors newbie

    Mar 22, 2011
    i believe i tried that but i will give it a go. i think i had a go and it didnt work due to the drive not being recognised as a hard drive by my computer.


Share This Page