external hard drive ejecting itself

Discussion in 'macOS' started by ghking, Apr 21, 2008.

  1. ghking macrumors regular

    ghking

    Joined:
    Jul 21, 2007
    #1
    hello
    i have a Beyond Micro mobile disk USB external hard drive connected to my imac running Leopard. Once in a while during it randomly ejects by itself and i get the "Unsafe Removal" warning pop up. I don't do anything to the drive at all. Is it a software thing? or is it about to bail?
     
  2. hodgjy macrumors 6502

    Joined:
    Apr 15, 2005
    #2
    What is the chipset on the usb controller? Some chipsets are more compatible with Macs than others.
     
  3. ghking thread starter macrumors regular

    ghking

    Joined:
    Jul 21, 2007
    #3
    not sure how would i find that out? it has been working for about a year this ejecting stuff has just started happening
     
  4. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #4
    First, try the drive on another machine if possible to see if it does the same thing.

    If the drive has been working for a year OK, it may be heading south....
     
  5. ghking thread starter macrumors regular

    ghking

    Joined:
    Jul 21, 2007
    #5
    yea i tried it on my emac too same thing
    crap
     
  6. Kate Apple macrumors newbie

    Joined:
    Dec 12, 2009
    #6
    External drives randomly eject-same problem

    I have an OWC Mercury Pro Elite and WD My Book. Initially both were hooked up via Firewire to 12" Powerbook. Both started to randomly eject. Recently have a new iMac and both drives are attached directly to USB ports on the back of the iMac. Same thing is happening. It doesn't happen during drive access, but it does happen 2-3 times a day, on either drive.

    Thanks for ANY help on this.
     
  7. nablake88 macrumors newbie

    Joined:
    Jan 22, 2011
    #7
    external WD hard drive ejecting itself

    im having the same problem please help
     
  8. ayyildiz macrumors newbie

    Joined:
    Jan 10, 2012
    #8
    Same thing with iMac 2010 and MacBook Pro 2011

    I recently purchased a CineRaid 4-bay enclosure. It works fine for a while then ejects itself and reconnects on Mac OS X machines. So, it is impossible to do any large transfers. I tried it on my iMac and my Macbook Pro (both running Lion), I got the same issue. When I connect it to a USB HUB it is almost impossible to do anything.
    I tried it on two different Windows machines (XP and Win 7) and did not see any issues. I transferred 500GB data and it completed without any issues. One version of Windows runs on my Macbook Pro on bootcamp and it has no issues with the CineRaid enclosure.
    I contacted the external enclosure manufacturer and they were surprised that I was seeing this issue. I am not sure whether this is a Mac OS issue that can be fixed by settings or the enclosure doesn't work with Mac OS X period. The manufacturer of the enclosure advertises it to work with Mac OS X 10.6 or later. Any opinion will be appreciated.
     
  9. teryg macrumors newbie

    Joined:
    Jan 24, 2013
    #9
    Same problem

    I just ran the system updates, which updated several things, including the operating system (now OS X 10.7.5, with all recommended patches installed). Suddenly, my LaCie external drive is constantly ejecting itself and giving me an improperly ejected error. The computer then freezes and has to be turned off and back on. I'm on a MacBook Pro. Is this happening to anyone else? I can't help but think it's related to the system update.
     
  10. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #10
    Which LaCie?
     
  11. LaCieTech macrumors member

    Joined:
    Jul 18, 2012
    #11
    Hi,

    Please call our support at 503.844.4500 or www.lacie.com/mystuff. The symptoms your describing indicate a corrupted volume which may have occurred during the OS update if the drive was attached during the update. We can discuss options and possible solutions with you.

    ~mn
     
  12. riza.dervisoglu macrumors newbie

    riza.dervisoglu

    Joined:
    Nov 28, 2016
    #12
    Thanks for this useful information! My two external drives were connected during an update (Sierra 10.12.3) and in the morning both were not-properly ejected. I will check the integrity of these drives now.

    With kind regards,
    Riza
     

Share This Page