External hard drive enclosure not recognised.

Discussion in 'Mac Accessories' started by davidoloan, Jan 14, 2014.

  1. davidoloan, Jan 14, 2014
    Last edited: Jan 14, 2014

    davidoloan Suspended

    Apr 28, 2009
    I bought a IT-CEO 3.5" Sata external hard drive enclosure.

    It has its own power supply and USB 3.0.

    The HD is a Samsung HD103SJ, 1TB, 7200rpm.

    A new iMac and a 2013 MacBook Air won't recognise it at all.

    The hard drive was formatted in Windows and has an iTunes music library I want to transfer.

    The enclosure appears ok in a Linux computer.

    The hard drive works perfectly when plugged directly into the second slot inside the Linux computer.

    I can get Western Digital external drives formatted in Windows to appear in the two Apple computers without any trouble but not this enclosure.

    Am I doing something wrong?
  2. RMo macrumors 65816


    Aug 7, 2007
    Iowa, USA
    I've had a USB 3.0 enclosure work fine on my Windows box but not on my Mac, but it worked fine once I replaced the stock USB 3.0 cable that came with the enclosure. In my case, I think the cable was bad, so, while unlikely, maybe that is also what's happening for you.

    As an interim measure (because I had no extra USB 3.0 cables) and as a test, I tried it with a USB 2.0 cable, and it worked fine. Perhaps you could see if that does anything for you. You don't have to keep it that way, but, like I said, it could be useful for testing to narrow down the possibilities.

    My first thought was that it might be some sort of file system incompatibility, but I can't think of any filesystem modern versions of Windows will let you use that OS X can't at least read (unlike when you go from OS X to Windows), and it sounds like you've done this successfully before.
  3. davidoloan, Jan 14, 2014
    Last edited: Jan 14, 2014

    davidoloan thread starter Suspended

    Apr 28, 2009
    Thanks, I will go and try a USB 2.0 cable.

    The USB 3.0 cable is working perfectly on a Linux computer, and so has the USB 2.0 cable I have just tried.
  4. davidoloan thread starter Suspended

    Apr 28, 2009
    USB 2.0 didn't work either.

    It is definitely something to do with the Apple computers.

    It's just not working.

Share This Page