External hard drive error after wake from sleep

Discussion in 'macOS' started by Bow Rekk, Sep 18, 2007.

  1. Bow Rekk macrumors member

    Joined:
    Jun 22, 2007
    Location:
    UK
    #1
    Right. The last couple of times I have woken my MBP up a box has popped up with a big red sign in the middle saying my external hard drive was removed unexpectedly and could have caused loss of data. I know this is not healthy and I would like to stop it doing this as soon as possible. It is connected via firewire 800 and is a western digital 250 gig my book pro if that makes any difference. I close the lid of my laptop with it still on and connected and everything is supposed to sleep. It used to work fine, I would open the lid and everything would wake up and I could do what I was doing before with no error messages and the hard drive would still be mounted on the desktop.

    Help please?

    Thanks very much.
     
  2. NATO macrumors 68000

    NATO

    Joined:
    Feb 14, 2005
    Location:
    Northern Ireland
    #2
    Same thing happens to me with 500GB MyBook Pro drives connected by FW800 on my Mac Pro. Can't figure out how to fix it...
     
  3. PCRanger macrumors regular

    Joined:
    Dec 12, 2006
    Location:
    London, UK
    #3
    Have you got the Western Digital software installed?
    This is all I can think of, as my Macbook wakes up fine with the external drive plugged in...
     
  4. Tymmz macrumors 65816

    Tymmz

    Joined:
    Jan 6, 2005
    #4
    I read that not every HDD is affected by this problem.

    Never had any issues with my G-Drive Mini or Lacie nor a friends WD HDD.

    But my new and shine G-Tech's G-Drive, the only one with a power on/off switch, exhibits such wrong behaviour.

    Has anyone found a solution to the problem or is it an inescapable problem.

    cheers!
     
  5. iMichael72 macrumors regular

    Joined:
    May 19, 2007
    Location:
    Maryland, U.S.A
    #5
    I get the same prompt also. But for me, it's the main hard drive.
    It will say Macintosh HD has been disconnected improperly, or something to this effect.
    I don't remember this happening before I upgraded to Leopard.

    This happens on my intel iMac 2 GHz Core 2 Duo.

    Thanks.
     
  6. Tymmz macrumors 65816

    Tymmz

    Joined:
    Jan 6, 2005
    #6
    I wonder what's causing these errors.

    Any ideas are appreciated.

    cheers
     
  7. ariesfeng macrumors member

    Joined:
    Apr 7, 2008
    #7
    I have the same problem on my new Simpletech 1TB external hd.

    Can anyone figure out what's going on here
     
  8. albcor8 macrumors newbie

    Joined:
    Feb 17, 2009
    #8
    I am (or was) in the same case. Let me tell you my story with details that might be useful. Excuse me in advance for the long post but I think in these cases, speaking about details, "the more the merrier":

    I have a MacBook and recently bought a Western Digital My Book Studio intending to use it for TimeMachine and some clone backup (I use the free version of SuperDuper... got to partition the disk). I have the device connected via Firewire.

    Anyway... I use to close the lid of the MacBook in order to get it to sleep. My surprise was that since the very first time using the external drive, it gives me the "Device Removal" Error when I wake the computer from sleep. It's supposed that this drive has some thing called "SmartPower" that automatically turns it on/off as the computer does, so anyone assumes that, of course, this would be without having to unmount the drive previously, right? But the Error makes the SmartPower feature useless... apparently.

    The problem occurred every time I woke the MacBook from sleep. From the beginning I installed the DeviceManager software included with the drive, so I had few options left to try.

    The thing is that I tried something and since then the error is no longer showing. I found this comment at some forum when I was "googling" for an answer and it gave me an idea:
    The idea was the next: I have the MacBook configured to ask for a password before waking from sleep and I noticed that I used to enter the key so fast after opening the lid that the external device was still waking up when I already got the OS working again. So, I tried to wait for the MyBook's LED Indicator to remain steady (ON) before I inserted the key, so that the device was already up and running before I got the MacBook OS (Leopard 10.5, by the way) working again. And, for my surprise, the error did not show anymore. I tried the same steps again and still no error shown. The problem is that after my success I tried inserting the key as quickly as before to prove myself that it was making the difference... but the error didn't show this way either! So... I don't know what happened but apparently I have not discovered the reason or maybe the problem is still there and it's just that the warning message is not showing anymore.

    I am even more confused now, hehe. Have not turned off the MacBook since that, so I don't know if this will be happening from now on or I just got lucky today. The only thing I remember doing before is that I once pressed the MyBook's ON/OFF button while both it and the MacBook were sleeping. This changed the drive from standby (LED flashing slowly) to power-save mode (LED steady) and, after waking up the system, the drive powered itself off without any error message. After that, obviously, I just turned the device on again and it started working fine. Anyway I just did it that one time, meaning that I didn't touch the MyBook's power button when I tried delaying my password entering when waking the MacBook on.

    Maybe some if this info would be useful for you. At least I leave it as history of base info. Bye now :D
    I'll let you know if I find out something else.
     
  9. sundevil671 macrumors newbie

    Joined:
    Mar 26, 2011
    #9
    Solution?

    I'm having this problem now with a brand new Western Digital external hard drive and my Mac Pro. Anyone find any answers to this yet?
     

Share This Page