External Hard drive help needed

Discussion in 'Mac Basics and Help' started by kuklenkoaddd, Dec 16, 2015.

  1. kuklenkoaddd macrumors newbie

    Joined:
    Dec 16, 2015
    #1
    My near 3 month old samsung 1tb external hard drive has just packed in. Whenever I plug it in it comes up with a message reading OS X can't repaid the disk "Samsung" You can still open or copy files on the disk, but you can’t save changes to files on the disk. Back up the disk and reformat it as soon as you can. It worked fine this morning and now it will not work at all.

    Anyway I have gone into disk utility and I have clicked erase and it will not allow me to do this either. Basically I need to format my external hard drive as quickly as I can so that I can re back up all of my work - but it will not let me. Do you have any tips?
    Please help

    Thanks!!
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    Sounds to me like some kind of permissions or access problem.

    If you can still copy files FROM it, the drive itself is still "spinning and well".

    Something quick to try:
    1. Click ONE TIME on the drive's icon (on the desktop) to select it.
    2. Type "command-i" to bring up the "get info" box.
    3. In the get info box, look down towards the bottom at the "sharing and permissions" area. If it's not visible, click the "disclosure arrow" to show it.
    4. What does it say?
     
  3. kuklenkoaddd thread starter macrumors newbie

    Joined:
    Dec 16, 2015
    #3
    Hi there Fishrrman

    I have done as you have suggested and it says "You can only read"

    It then have a small 't' table split by Name and Privilege. It says System can read and write, wheel can read and write and the everyone can read only.

    Does that help and what would you do next?

    Thanks!!
     
  4. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #4
    "I have done as you have suggested and it says "You can only read""

    I don't believe there's anything wrong with the drive (physically) at all.

    Try this next:
    1. Open up the get info window again.
    2. In the lower-right-hand corner, there should be a lock icon.
    3. Click it and enter your administrative password. Does it let you do this?
    4. In the lower-left-hand corner of the get info window, put a checkmark into the box that says "Ignore ownership on this volume".
    5. Close the get info window.

    Assuming the finder lets you put the checkmark into that box, can you copy files to the drive now?
     
  5. kuklenkoaddd thread starter macrumors newbie

    Joined:
    Dec 16, 2015
    #5
    Hi

    Thanks for your help so far may I say.

    Again I have done everything you have suggested. However, when I click the lock button in the lower left corner and put in my password, nothing changes on the info screen. I am able to unlock it not a problem, but I am not given a box that allows me to "Ignore ownership problem".

    Is there anything else that I can try?

    Thanks.
     
  6. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #6
    Could you take a screenshot of your "get info" box for the drive and post it here?
     
  7. phrehdd macrumors 68040

    phrehdd

    Joined:
    Oct 25, 2008
    #7
    Is the drive USB3 or TB? If the former, have you tried a different cable or port? While it is rare, it does happen where the cable is the problem or the connection between the device and the computer (either port on the device or computer). As well using a US2 port for a USB3 drive can create issues. What I am suggesting is just being sure it isn't this odd potential for issues. I think Fishrrman has given you great advice.
     
  8. kuklenkoaddd thread starter macrumors newbie

    Joined:
    Dec 16, 2015
    #8

    Hi guys, thanks for responding - it is a USB 3.0 for the record, so do you think that could cause issues?

    And as for the screenshot - sure - its attached to this comment and that shot is once I have opened the lock - I cant scroll any further down than that. Thanks again for your help!
     

    Attached Files:

  9. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #9
    First thing that I notice is the Format: MacOS Extended (Case-sensitive)

    I don't ever recommend using the case-sensitive option, unless you have a specific need for that.
    I don't think that would be causing your issue, but just not normally a good option for most users.

    I also notice that adding a user (the (+)) is greyed out...
    Can you click the drop down next to "everyone", and change from "Read Only" to "Read & Write"?
    Maybe that will let you erase the drive. Reformat to Mac OS Extended (Journaled). Do not choose the Case-Sensitive option.
     
  10. Fishrrman, Dec 24, 2015
    Last edited: Dec 25, 2015

    Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #10
    I agree with DeltaMac above about "case sensitive".

    I suggest you re-initalize the drive to:
    Mac OS Extended (Journaled)
    ... but leave out the "case sensitive" option.


    Addendum:

    What follows is from my archives. I have never had the need to try this myself.
    It -might- work for you.

    Note that the list of terminal commands below contains one routine for drives with a single, continuous name, and another routine for if your drive name is more than "one word". By more than one word, I mean that a space character has been used in the drive name.

    In Terminal type the following sequence (obviously replace "Volumename" with the name of your volume):

    For a drive with a "one-word name":
    sudo chflags 0 /Volumes/Volumename
    sudo chown 0:80 /Volumes/Volumename
    sudo chmod 775 /Volumes/Volumename
    sudo chmod -N /Volumes/Volumename

    For a drive with a name that has MORE THAN one word:
    sudo chflags 0 /Volumes/firstname\ secondname
    sudo chown 0:80 /Volumes/firstname\ secondname
    sudo chmod 775 /Volumes/firstname\ secondname
    sudo chmod -N /Volumes/firstname\ secondname
    or like in my example:

    Here is an example for a drive named "My HD":
    sudo chflags 0 /Volumes/My\ HD
    sudo chown 0:80 /Volumes/My\ HD
    sudo chmod 775 /Volumes/My\ HD
    sudo chmod -N /Volumes/My\ HD

    A brief description of what each line does (as I understand them):
    chflags 0 removes all flags from the file(s)
    chown 0:80 ensures root:admin (owner:group) permissions so the system can access the files
    chmod 775 adjusts file permissions so you and your group have read/write/execute permissions
    chmod -N removes the ACL (Access Control Lists) from the named file(s)


    Again, I've never had the need to try this.
    If you try it, please let us know if it worked for you!
     
  11. LiveM macrumors 6502a

    LiveM

    Joined:
    Oct 30, 2015
    #11
    I had the same issue with a new WD drive but I used the WD utility to erase the disk.
     
  12. satcomer, Dec 27, 2015
    Last edited: Dec 30, 2015

    satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #12
    Take note everyone! I have used externals most of my Mac days(since 1998) and go had my fair share of failures to hard drives dying or controller circuits failing. So I gave up buying third party externals I went to buying an empty external (from OWC 0 Externals - don't worry they also ship overseas to places that Brown or FedEx deliveries) and put in the Best Reviewed hard drives for 2015!

    This way in the future if a hard drive fails then I vocal just replace the drive! The OWC 0 externals have been rock solid case wise for over 5 years! One with only one drive in it using Carbon Copy Cloner to it weekly!
     

Share This Page