External hard drive in exFat not working

Discussion in 'OS X Mountain Lion (10.8)' started by blikecray, Jul 25, 2012.

  1. blikecray macrumors newbie

    Joined:
    Jul 25, 2012
    #1
    I have an external hard drive that I created in Lion formatted it exFat. Upgraded today to ML then plugged the drive in and turned it on, a little pop up appears saying my iMac doesn't recognize this drive. I tried repairing the permissions in Disk Utility to no avail..works fine on my laptop which is still running Lion.

    All my music, movies, etc is on this drive..Not sure what else to do to get it work besides maybe a clean install of Mountain Lion? I had originally just upgraded.
     
  2. nurulknight macrumors newbie

    Joined:
    Jul 26, 2012
    #2
    Same Problem

    I have 5 external hard drives that I formatted ages ago as exFAT. All was fine until I upgraded to Mountain Lion and then rebooted my machine.

    Now all the hard drives are there, but I cant write in them. I looked on the internet, but this thread seems to be the only one who has seen this problem.

    I have made a booking with the Genius Bar, but wanted to see if anyone has any ideas? Thanks!
     
  3. DreamLand macrumors member

    Joined:
    Jan 10, 2009
    #3
    I have one HD that is formatted using exFAT, and it is working fine with Mountain Lion.
     
  4. nurulknight macrumors newbie

    Joined:
    Jul 26, 2012
    #4
    Not all drives are the same

    Hi

    I know its very weird. I have 5 buffalo hard drives and 1 western digital and one portable toshiba drive. All exfat.

    The western digial, and portable toshiba are all fine. The buffallos, two are over 2 years old and work fine and the ones that are 1 year old are not.

    It maybe the drive itself, I dont know, but I cant see why exfat is ok on some but not others. At the moment I am scrambling about finding spare drives to move content across, so I can format it again and see if it makes any difference...
     
  5. blikecray thread starter macrumors newbie

    Joined:
    Jul 25, 2012
    #5
    Are you running ML on an SSD? I'm almost positive all of my issues are because of my SSD. I have an iMac that I put a OCZ Vertex Plus in it when I had Lion, everything seemed fine. Then upgraded to ML and all my drive issues are happening. I tried a clean install and I'm still getting the same issue I can't mount or view any of my exFat external drives (tried two portable drives by WD and they work without a problem but they were FAT).

    Right now my only option is to update the firmware on my SSD or switch back to a hard disk, which means opening my iMac yet again (dreadful process).

    Let me know what the Genius bar tells you please!

    Here's the thread I found about SSD's and ML: http://forums.macrumors.com/showthread.php?t=1409151
     
  6. blikecray thread starter macrumors newbie

    Joined:
    Jul 25, 2012
    #6
    My issue was solved (OCZ Vertex Plus) I had 3.02 firmware, used a windows machine to upgrade to 3.55 firmware then used OCZ tools to do a secure erase (not the same as using disk utility, this is much better) and installed a fresh copy of ML without any of my previous issues (external hard drives not showing up, random reboots, etc.). Whew, finally!
     

Share This Page