External hard drive is not detected

Discussion in 'Mac Basics and Help' started by unicornpower, Jan 3, 2012.

  1. unicornpower macrumors newbie

    Joined:
    Jan 3, 2012
    #1
    Hi all,

    Sorry mods if this is in the wrong section, please feel free to move it if it is!

    I need a bit of help with my external hard disk that was primarily used with my old PC... It has two partitions on it, one NTFS and the other FAT32, and I basically wanted to erase everything that was on it to make it compatible with my Macbook Pro (currently running OS Snow Leopard). I used Disk Utility on the quickest erase setting to format it and it went through successfully. However, I noticed that it wasn't able to remove some invisible files that was still on the disk (it showed it had a usable disk capacity of 39GB but it had 100MB used for no reason after the format), so I ran Disk Utility's erase function again, but this time on the most thorough setting (I forgot what it's called, but it's the highest secure erase option). The process failed and displayed an error:

    2012-01-03 11:15:49 +0000: Mounting disk
    2012-01-03 11:15:50 +0000: Erase complete.
    2012-01-03 11:15:50 +0000:
    2012-01-03 11:18:28 +0000: Preparing to securely remove data from disk : “IBM Travelstar”
    2012-01-03 11:18:28 +0000: DOD Compliant 7-Pass Secure Erase (DOD 5220-22 M)
    2012-01-03 11:47:03 +0000: Secure Disk Erase failed with the error:

    Securely erasing data to prevent recovery failed.
    2012-01-03 11:47:04 +0000: Preparing to erase : “IBM Travelstar”
    2012-01-03 11:47:04 +0000: Partition Scheme: GUID Partition Table
    2012-01-03 11:47:04 +0000: 1 volume will be created
    2012-01-03 11:47:04 +0000: Name : “IBM Travelstar”
    2012-01-03 11:47:04 +0000: Size : 40.01 GB
    2012-01-03 11:47:04 +0000: File system : Mac OS Extended (Journaled)


    The drive appeared again, and I stupidly should've tried to repair the disk, but instead I ran the erase function and it displayed another error:

    2012-01-03 11:47:04 +0000: Error with partition Assert: internal error or unimplemented
    2012-01-03 11:47:04 +0000: Erase complete.
    2012-01-03 11:47:04 +0000:
    2012-01-03 12:26:27 +0000: Preparing to erase : “Untitled”
    2012-01-03 12:26:27 +0000: Partition Scheme: GUID Partition Table
    2012-01-03 12:26:27 +0000: 1 volume will be created
    2012-01-03 12:26:27 +0000: Name : “Untitled”
    2012-01-03 12:26:27 +0000: Size : 40.01 GB
    2012-01-03 12:26:27 +0000: File system : Mac OS Extended (Journaled)

    2012-01-03 12:26:27 +0000: Unmounting disk
    2012-01-03 12:27:14 +0000: Creating the partition map
    2012-01-03 12:27:14 +0000: Disk Erase failed with the error:

    Some information was unavailable during an internal lookup.
    2012-01-03 12:27:14 +0000: Erase complete.


    Now the drive doesn't appear at all when I plug it in! :( I hope I haven't royally screwed it up, but does anyone have any idea what I can do to get my computer to detect it again so I can fix it? Really appreciate any help I can get, thanks all!
     
  2. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #2
    Could be a bad USB cable or a problem with the drive. Unplug the drive from the Mac, reboot the Mac, then launch Drive Utility and plug in the drive -- see if it appears. If so, try partitioning the drive with 1 partition instead of doing the erase. If you keep having problems then it sounds like a hardware issue to me.

    I'm assuming you're connecting the drive to the back of your Mac and not to a USB hub or the port on your keyboard, by the way.
     
  3. nippyjun macrumors 65816

    Joined:
    Jul 26, 2007
    #3
    Hi,
    Can you plug it back into your pc and format it with fat32 and also run a disk check there to see if it's ok.
     
  4. unicornpower thread starter macrumors newbie

    Joined:
    Jan 3, 2012
    #4
    Thanks for your reply, guys! :)

    smirk: I thought it might be a bad USB cable so I've placed an order for a new one, hopefully it will be able to read it when it arrives... I've tried rebooting several times, plugging it back in once restart is done, but nada. :( Yes, I've been connecting the drive straight into the computer (I'm using a Macbook Pro by the way).

    nippyjun: I don't have a PC anymore... sold it off already... :( But now that I think about it, my flatmate has one so I'll try it out on his.

    Will update on my progress soon!
     
  5. unicornpower thread starter macrumors newbie

    Joined:
    Jan 3, 2012
    #5
    No luck with the PC... it did detect it and tried to install drivers to run it, but it didn't show up in My Computer at all. Hopefully the USB cable may be able to make a difference... but it's starting to look like a hardware failure. :(
     
  6. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #6
    That's good that it detected it. The drive won't show up in My Computer if the volume is formatted for Mac. Right click on My Computer and choose Manage, then click on Disk Management on the left (I'm not in front of a computer so that wording may be a bit off). On the right you should see a graphical list of all drives connected. You should be able to partition and format the drive from there as NTFS. Depending on what state the partitioned volumes are in you could right click on the graphical depiction below and take options to delete or unallocate the partitions, and then format the entire drive as one partition. Once that is done you can run chkdsk to scan for bad sectors if you want, or you could just assume it's fine now and ready to be formatted for Mac use (on the Mac).

    Good luck!
     
  7. unicornpower thread starter macrumors newbie

    Joined:
    Jan 3, 2012
    #7
    Hi smirk, thanks a lot for your advice, I followed it to a T but it doesn't even register in disk management at all... :( What else can I do?
     
  8. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #8
    Hi, I'm afraid I don't have any more advice. If you connect the drive to a computer and it doesn't even show up, it sounds to me like the drive (or drive case or case power supply or cable) is bad. Just seems kind of oddly coincidental that it worked until you formatted it, and now it doesn't even show up as a device.

    Hopefully someone else has a suggestion.
     
  9. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #9
    "What else can I do?"

    Do you mind spending about $20?

    If nothing else seems to be working, I'd suggest you do this:

    11. Open the old hard drive enclosure, and remove the drive itself from the enclosure (so that you have a "bare drive in hand").

    2. IMPORTANT QUESTION: Is the bare drive a "SATA" type drive? Or... is it an old "IDE" drive?

    3. If it's a SATA drive, get one of these:
    http://www.amazon.com/s/ref=nb_sb_noss?url=search-alias=aps&field-keywords=usb+sata+dock&x=0&y=0
    (many items shown, they all work the same, just get one you like that's cheap)

    4. Once you have the dock, put the drive into the dock, plug the dock into the Mac, turn it on, and open Disk Utility. Can you now "see" the drive to initialize it?

    If this doesn't work, I'm _guessing_ that there is some kind of hardware problem with the drive itself, either with the drive's controller board, or inside with the platters, etc.

    These "docking stations" are very useful gadgets to have around, if you encounter "drive problems"....
     
  10. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #10
    That old 40GB PATA Travelstar is probably at the end of its life. Considering 32GB USB Flash drives can be had for a song I'd retire it before you actually lose data on it.
     
  11. unicornpower thread starter macrumors newbie

    Joined:
    Jan 3, 2012
    #11
    Thanks all for the help, have already scrapped that hard drive.
     

Share This Page