External Hard Drive Issues....I think I have tried everything

Discussion in 'Mac Basics and Help' started by bimmeracer, May 24, 2012.

  1. bimmeracer macrumors regular

    Oct 13, 2008
    Hi, Any help will be greatly appreciated.

    I ran ipartition on one of my external hard drives to extend one of the partitions and due to the fact that it was taking forever, I decided to abort it. A few hours later I forced shut down my MBP since it wouldnt turn off. When I rebooted my MBP I noticed that my external hard drive was not showing up. After a ton of google searches and trying different methods with no luck I am hoping to find some help here.
    The disk shows up in disk utility but cannot be mounted. Also, it shows up as ExFAT

    When I tried Disk utility "repair disk" I received:
    Verify and Repair volume “disk2s1”
    Checking volume.
    Checking main boot region.
    Main boot region is invalid. Trying alternate boot region.
    Checking alternate boot region.
    Alternate boot region is invalid.
    The volume could not be verified completely.
    Volume repair complete.Updating boot support partitions for the volume as required.Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.

    I tried TestDisk and used the boot repair and received:
    testdisk Can't write new NTFS boot sector

    i also tried Data Rescue and it was also unable to fix or recover anything from the hard drive.

    Any other suggestions?

  2. miles01110 macrumors Core


    Jul 24, 2006
    The Ivory Tower (I'm not coming down)
    I'd say it's time to cut your losses and either wipe it entirely and start over or, if that's not possible, buy a new drive.
  3. johto macrumors 6502


    Jan 15, 2008
    Its toast. Just bite the bullet and repartition / format the drive.
    You do have backups, right? :eek: :rolleyes:


    You cant "f00bar" disk permanently in "sofware level". I see no reason why erase/repartition/format woudnt work.
  4. bimmeracer thread starter macrumors regular

    Oct 13, 2008
    I run CCC daily and luckily it backed it up a few hours before this happened. I run a photo + video production company and that partition was my main media hard drive. I would of been devastated if I didnt have a backup since that drive contains 8 weddings.
    I was doing some video work and I am not sure how far into it I got before this error happened.
    I would like to make sure I have exhausted all reasonable options before calling it quits. If nothing works, I will just have to format the drive and start over.

  5. Fishrrman macrumors G5


    Feb 20, 2009
    "If nothing works, I will just have to format the drive and start over. "

    If you have current CCC backups, doing this would be the easiest route, by far.

    Boot up from your backup drive, then...
    Just re-initialize and re-partition the drive, then...
    Just "re-clone" your respective partitions to the original drive.

    The only disadvantage will be that it takes time to do the copying...
  6. bimmeracer thread starter macrumors regular

    Oct 13, 2008
    I would like to try one more thing. What windows 7 programs are comparable to TestDisk, Data Rescue, etc?
    I have had no luck with google.
  7. Elbert C macrumors 6502

    Mar 23, 2008
    AK, USA
    If you don't mind spending $99.95, try DiskWarrior. If DW doesn't repair it, nothing will.
  8. bimmeracer thread starter macrumors regular

    Oct 13, 2008
    Tried it. I guess im..... :(
  9. Fishrrman, May 26, 2012
    Last edited: May 27, 2012

    Fishrrman macrumors G5


    Feb 20, 2009
    "i also tried Data Rescue and it was also unable to fix or recover anything from the hard drive.
    Any other suggestions?"


    You could try this:
    1. Use Disk Utility to RE-INITIALIZE the drive into a SINGLE partition.
    2. Do not, repeat DO NOT, choose the option to "zero data". You ONLY want to replace the directory with a "clean" one, you DO NOT want to "touch" any data on the drive's sectors.
    3. Now, view the [apparently] "empty" volume using Data Rescue.
    4. Have DR do a "deep search" of the entire drive -- this will take time. It might help to "limit" DR's search to certain file types (example: jpeg) that you may be trying to recover.
    5. If DR finds data that you are looking for, you will need ANOTHER "scratch drive" to which DR can reconstruct and save the data files.

    Why this may work:
    Your drive probably had a completely corrupted directory and/or partition map. However, the actual -data- on the drive's platters may still be there, unharmed.

    Remember that re-initializing a drive "wipes clean" the drive's directory ONLY. Data that is actually on the platters is left untouched, only the references to where that data are get replaced during the re-initialization process. Thus, although the drive may mount and show as "empty space" on the desktop, the data is "still there", waiting to be over-written.

    Data Rescue (and other file recovery apps) is designed to "work around" the directory. That is, DR "goes right to the platters", and scavenges every sector. If it finds data there, it attempts to re-assemble the data files on its own, without help from the directory. Thus, it can recover files from the drive, even though when you mount the newly-initialized drive on the desktop, it says there's nothing on it.

    I used this procedure to recover many gigabytes of mp3's from a drive partition that had become corrupted and un-mountable. Data Rescue couldn't "get to" the bad partition, because it -was- "un-mountable" and could not be "put on the desktop". By re-initializing the drive into a single partition, I was able to mount it, and I set up DR to search for mp3 files, and got nearly all the data back!
  10. dcwang3 macrumors newbie

    Dec 26, 2012
    I am having the same problem with my hard drive. I accidentally unplugged my Lacie HD out of my mac without unmounting it, and it started having that problem. I have done that many times accidentally but I guess this is the first time it decided to crap out on me.

    So, looking at "Fishrrman's" post. How exactly would you re-initialize the single into a single partition without the option to zero data? I do not see anything option or anything within Disk Utility.

    If anyone could help me figure out that procedure, that would be great!

    PS - My HD was formatted for NTFS and used with mac w/ paragon NTFS
  11. dcwang3 macrumors newbie

    Dec 26, 2012
    any suggestions or help regarding this issue?

Share This Page