External Hard Drive keeps ejecting / mount issues

Discussion in 'OS X Yosemite (10.10)' started by StevieG03, Apr 11, 2016.

  1. StevieG03, Apr 11, 2016
    Last edited: Apr 14, 2016

    StevieG03 macrumors newbie

    Joined:
    Apr 11, 2016
    #1
    Hi Guys,

    I was wondering if anyone has a solution to my problem?

    I'm currently having issues mounting external hard drives via USB 3 (1 seagate and Western digital) on desktop (Mac Mini 2012). They mount and then seem to eject randomly. I've been doing my research for a couple of weeks and everything I have tried doesn't seem to work? But the strange thing is that is it seem to mount perfectly fine on my Mac Book Pro 2011 also running Yosemite.

    So far I have tried:

    -Turning off Power saving

    -Turning off Spotlight to stop it indexing the drives

    -Have run the Kext Utility

    -Have used Terminal to run the below script:
    sudo /System/Library/Filesystems/hfs.fs/Contents/Resources/hfs.util -N /dev/disk3s2
    to turn off the journaling bit.

    -Have tried a different USB 3 cable

    -Even tried a tried a migration assistant from the Mac Book Pro to the Mac Mini to see if it was a setting issues that I missed, but it still ejects them or doesn't even mount, so the HD doesn't seem to be the problem it seems to be something in the operating system?

    - Have run a hardware fault test and it's all clear.

    Any help would be appreciated, as its been driving me mad!!! (P.S. I'm not a tech expert but know the basic so a simple explanation would be great if possible Thanks)
     
  2. StevieG03 thread starter macrumors newbie

    Joined:
    Apr 11, 2016

Share This Page