External hard drive locked with limited access

Discussion in 'Mac Accessories' started by aoitsukinosuke, Jul 2, 2012.

  1. aoitsukinosuke macrumors regular

    Joined:
    Jun 13, 2011
    #1
    I have a MacMini running Leopard 10.5.8 and have 3 external storage devices.
    Yesterday, I turned on the one with my media files, Samsung Story 1GB, I got a warning.
    http://forums.macrumors.com/attachment.php?attachmentid=346231&stc=1&d=1341234647
    Then, I tried Disk Utility but repairing options were grayed out except Verify Disk.
    http://forums.macrumors.com/attachment.php?attachmentid=346232&stc=1&d=1341234742

    When I tried that, I got another warning. (I tried to get the screenshots)
    http://forums.macrumors.com/attachment.php?attachmentid=346235&stc=1&d=1341234973

    I can access the files, but can't edit or move any of them.

    Going thru some forums, being very unfamiliar with Terminal, I nevertheless entered
    ls -alOe /Volumes in the Terminal screen and got the following.

    james-belgins-mac-mini:~ jamesb$ ls -alOe /Volumes
    total 8
    drwxrwxrwt@ 4 root admin hidden 136 2 Jul 02:36 .
    drwxrwxr-t 35 root admin - 1258 2 Jul 02:32 ..
    lrwxr-xr-x 1 root admin - 1 2 Jul 02:31 Macintosh HD -> /
    drwxrwxr-x@ 35 jamesb staff - 1258 27 Jun 18:00 SAMSUNG
    0: user:jamesb allow list,add_file,search,add_subdirectory,delete_child,readattr,writeattr,readextattr,writeextattr,readsecurity
    james-belgins-mac-mini:~ jamesb$

    I can't reformat the disk as I would lose all data. The free space on my Mac's hard drive is not big enough for copying all files and I have no way of getting a new external soon.

    Can anybody help me please?
     

    Attached Files:

  2. Brian33 macrumors 6502a

    Joined:
    Apr 30, 2008
    Location:
    USA (Virginia)
    #2
    You've given a good description of your problem and seem to have tried the sensible things, but unfortunately I don't have the knowledge to tell you much about the Disk Utility errors. My guess is that you won't be able to fix this without a format (if then, even).

    My advice would be to turn off the SAMSUNG drive and leave it off until you can afford to get a new hard drive, and at that time try to copy all the files.

    (Brace yourself for a lot of people saying "This is what backups are for...")
     
  3. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #3
    It's not free, but many here have had good results with Disk Warrior:

    http://www.alsoft.com/diskwarrior/

    I think a utility like this may well be your only hope of getting that data off...You are going to have to beg, borrow or steal (not really) a cheap external with sufficient capacity if you do get access....It might be a one hit chance. Good luck.
     
  4. cloughenough macrumors newbie

    Joined:
    Jul 3, 2012
    #4
    I had the same symptoms with my external Promise Pegasus R6 drive; I tried many different things, and finally purchased and downloaded Diskwarrior; it fixed it! What a relief. Promise tech support was not able to help, and I am still unsure what caused the problem in the first place.
     

Share This Page