External hard drive - major problems :(((

Discussion in 'Mac Basics and Help' started by RedThread, Jun 29, 2010.

  1. RedThread macrumors newbie

    Joined:
    Jun 29, 2010
    #1
    Hello!

    I'm brand new here and am not sure whether I can find help for this here, but here's my quandry anyway:

    I have a MacPro running OS 10.5.8, and a Simpletech 1TB USB drive (I think it's this one http://www.simpletech.com/parts/spu351tb.htm )... It has 2 partitions. I've had the occasional problem but nothing disasterous until today. As of today, sometimes the computer and utilities are not recognizing the drive, other times it's crashing any program which is associated with it, including the Finder when copying files. I've tried Disk Utility as well as DiskWarrior, and have tried all sequences of unplugging/restarting. Further detail below...

    I really need these files!!! It's my work folder as well as much important and sentimental stuff. I bought another 1TB drive to attempt to copy the files over, but haven't tried yet as things seem to be in such poor condition at the moment.

    It basically goes one of three ways, seemingly at random:

    1. It doesn't show up on desktop or disk utility (restart/replug required);

    2. It doesn't show up on desktop but does in disk utility (but cannot be mounted, first aided, or otherwise dealt with... restart/replug required);

    3. It shows up on desktop and in utility, but eventually (somewhere between 1 and 5 minutes later) crashes any program that tries to use it, including "finder" while copying files off of it.

    I've made screenshots of several reports from Disk Utility and DiskWarrior about the status and errors... I can see that the disk is fragmented or whatever, but don't know how I can fix it at this point :*(

    PLEASE let me know if you have any ideas or insight. It's the worst timing since I'm in the middle of a layout project. Lame.

    THANKS A MILLION :eek:

    ~ Marrie
     
  2. gorillamarker macrumors newbie

    Joined:
    Jun 30, 2010
    #2
    it seems like your actual connections to the drive are loose, whether it'd the actual wire are the chip that connects to your drive.

    I would suggest first looking to see if anything is noticeably loose with the hd.

    And on another note, if you need a data recovery tool, Data Rescue 3 is by far the best I have ever used.
     
  3. gorillamarker macrumors newbie

    Joined:
    Jun 30, 2010
    #3
    also,

    sorry if you have already done this, but have you tried verifying the disk with disk utility.

    If it still crashes the program put in your install disk and boot from it. Then open disk utility in the menu bar.

    This article briefly describes how to do it in verify disk:

    http://www.mactipjar.com/content.php?20-Speed-Up-Your-Mac


    Hope any of this helps and sorry if it hasn't.
     
  4. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #4
    Marrie,

    The symptoms you described are, beyond a doubt, a mechanically failing hard drive.

    Drives can fail in a lot of different ways. In your case, the drive's internal components are trying to test themselves, and they're having a difficult time doing so. If and when your drive appears in Disk Utility, it was able to get past the first set of basic tests, but as soon as your Mac tries to read some files from the drive, the drive has trouble reading itself. It will keep trying for a while (hence the delay), and does its best to show the computer what's on the drive. However, when it runs into a part that it cannot read, the Mac keeps waiting indefinitely for the drive to respond, and it never does.

    If your files are important, you need professional cleanroom data recovery.

    Best wishes.
     

Share This Page