External Hard drive (Maxtor) alive but dead.

Discussion in 'Mac Basics and Help' started by alicat, Jun 29, 2010.

  1. alicat macrumors newbie

    Joined:
    May 23, 2007
    #1
    Hi all

    Have googled this for a while, seems a few people have issues, but appears that there has been limited success in resolving this issue. Maybe you can help.

    I have an External Maxtor Hard drive that I partioned to hold my TM data and to use as a separate drive to store files. No problems previously with installing updates or TM activities.

    However, after installing the 10.5.8 update at the start of the month. I noticed when I next plugged in the hard drive for my weekly TM backup, it did not appear.

    The disk will appear on my old ibook and on my newer machine at work, as the data only. Thankfully.

    But I would really like it to appear back on my everyday machine. (Macbook 2.4 GHZIntel Core2 Duo)

    I unpluggged everything, powered down and restarted, reconnected the hard drive but no joy.

    I changed my firewire cables to see if something was broken (power is on to the drive fine). No joy.

    I then tried the PRAM restart. No joy.

    I then checked my Finder preferences to make sure the external drives tick box was selected. No joy.

    I then checked the disk utility, but no joy.

    I then double checked that the data was available on my old machines at home and newer machine at work. Joy.

    But no joy when connecting back to my laptop with the TM data is sourced.

    Is there another fix to look at, or if I need to remove my data , and forgo all my TM data, how do I go about reformatting the drive if it is not appearing.

    I have checked software updates, and there are no new releases (ie if this was a bug, as what seems to happen regularly with airtunes, a couple of days later a fix comes through)

    Any ideas would be greatly appreciated. I am scratching my head here.
    ali
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    It's possible that the drive is completely fine but the enclosure is busted thus grab a new enclosure and and take it out from the original enclosure and put it in the new one and try again
     
  3. alicat thread starter macrumors newbie

    Joined:
    May 23, 2007
    #3
    Hi Hellhammer.

    The drive is super encased, so I will leave your suggestion till the end, I would need a hacksaw to get into it! :)

    I borrowed and old firewire drive from work that I had used previously to transport work home. It worked fine at work, but not on the laptop. I am beginning to think it is the firewire port on the laptop?

    You can hear the harddrives power up, but no mounting.

    A few googles of the forum, such as
    http://forums.macrumors.com/showthread.php?t=883719

    suggests that this has been a common occurrence since the 10.5.8 update, for a lot of people. :(
     
  4. alicat thread starter macrumors newbie

    Joined:
    May 23, 2007
    #4
    Well how bizarre.

    Four PRAM bells, the beast is back.

    WT? Oh well I am happy now.:p
     

Share This Page