external hard drive no longer connected?!?!?!

Discussion in 'Mac Accessories' started by veeco3110, Aug 22, 2008.

  1. veeco3110 macrumors 6502

    veeco3110

    Joined:
    Aug 29, 2007
    Location:
    brick nj
    #1
    today my mac for some reason or another froze. well not froze but acting very sluggish. figured the 4 gig of memory would have solved that.((running only 5 programs mind you))

    so i do a hard restart of the computer((pressing and holding the power button)) and when i come back my external is no longer there. hasnt been connected all day!

    its a western digital 500 gig hard drive. i disconnected everything on it and re instaled it. nothing. i just get the spinning light in the front. bought it in december of 07.


    any ideas of what could be wrong or what i can do to fix it???
     
  2. waw74 macrumors 68030

    Joined:
    May 27, 2008
  3. veeco3110 thread starter macrumors 6502

    veeco3110

    Joined:
    Aug 29, 2007
    Location:
    brick nj
    #3
    nope not being recognized by my computer at all...

    for those familiar with the WDs the circle on the front is spinning. if i power it off i can hear the hard drive spin up. i still hear the fans going at a nice soft wizz. its just not coming up on disk utility or anywhere on my computer.
     
  4. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    NY State of mind
    #4
    got another external drive you can try on the Mac? Have a PC around you can try to plug the drive into?
     
  5. veeco3110 thread starter macrumors 6502

    veeco3110

    Joined:
    Aug 29, 2007
    Location:
    brick nj
    #5
    Nope only computer is my mac. It lights up. Acts like it's loading. Then that's it. Doesn't connect nothing. Any programs to get my pictures off it. That's all that I want
     

Share This Page