External hard drive no longer recognised

Discussion in 'MacBook Pro' started by chrisnas, May 4, 2014.

  1. chrisnas macrumors newbie

    Joined:
    May 4, 2014
    #1
    Hey everyone. I've been using a 1TB WD Elements external hard drive for around 2 years now with my macbook pro and it worked perfectly. However, after i updated to mavericks the external no longer shows up in finder. I've tried some of my other externals and they dont show up either. It does, however, show up in disk utility. My externals work fine on my brothers laptop, they just dont show up on mine. Is there any way to fix this?
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Have you checked this :

    Finder / Preferences / General, and Finder / Preferences / Side bar, is the tick box "External disks" checked ?

    If it is already checked, or has an hyphen in it, uncheck then check again.

    Also, since you've updated to Mavericks, repair the permissions in Disk Utility, just in case.
     
  3. chrisnas thread starter macrumors newbie

    Joined:
    May 4, 2014
    #3
    Yep boxes are both checked and it still doesn't show. When I click repair disk, it says the disk cannot be repaired and that it needs to be restored. Would you have any idea why it's only my MacBook that has this issue?
     

Share This Page