External Hard Drive Not Mounting

Discussion in 'MacBook Pro' started by S3CR3T, May 14, 2017.

  1. S3CR3T, May 14, 2017
    Last edited: May 15, 2017

    S3CR3T macrumors newbie

    S3CR3T

    Joined:
    May 14, 2017
    #1
    I have researched this relentlessly and my specific scenario seems to not be anywhere....

    I own an early 2015 MacBook bro (16gb RAM, 3.1 i7)

    Just yesterday it stopped detecting my 2TB seagate hard drive. The day before that it was working fine. In fact the last time I used it I had copied 40gig worth of files over to it. Worked completely fine and I ejected it. The next day when I plugged it in my Mac would not mount it or recognize it in Disk Utility.

    Here is the kicker... It shows up in my USB Device Tree. If I launch disk utility while it is plugged in then it loads forever. If I launch Disk utility before I plug it in, then it simply won't show up.

    It is important to note I got it to work once. Not sure how, I simply restarted the computer and plugged it in again and it worked. However, next time I tried it did not work and still hasn't up until now.

    I'm on the road and unfortunately only have access to this Mac.

    UPDATE: hilariously enough. After copying all the files to my new hard drive the whirring has completely stopped when I use my old hard drive by itself. Before transfer it took my computer a good 10 minutes just to load the files on my hard drive. Now that is completely gone too and it seems to be working perfect now. I still won't use it to be safe... but it's kind of frustrating to say the least.
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    Sometimes hard drives just fail. That's all there is to it.

    Does the drive "spin up" when you connect it?
    Can you hear the platters moving inside?

    Is the drive "bus powered" (i.e., portable)?
    Does it have a removable/replaceable USB cable?
    Have you tried it with A DIFFERENT connecting cable?

    Have you tried it in the MacBook's OTHER USB port?

    One thing to try (no promises).
    Do this in order:
    1. Power down, all the way off.
    2. Disconnect the external
    3. Boot the MacBook to the finder
    4. Connect the external, and then...
    5. ... just "wait a while".
    Give it up to 30 minutes. Sometimes if a drive won't mount, the finder seems to "work behind the scenes to repair it and get it mounted.

    IF the drive suddenly mounts up, the FIRST THING YOU WANT TO DO is copy anything critical off of it to your internal drive. Just in case it won't mount again.

    Final thought:
    I guess when traveling, it's handy to have MORE THAN ONE external or backup drive.
    Can help with situations like the one you're in.
    Good quality, high-speed, high capacity USB3 flash drives can be an alternative.
     
  3. ZapNZs macrumors 68000

    ZapNZs

    Joined:
    Jan 23, 2017
    #3
    You could download a SMART utility such as SmartMonTools or DriveDX - it will likely be able to pull SMART Data from the drive if it shows up in the tree. It is possible that the drive is OK and something is wrong with the enclosure or cable being used?

    Can you hear the drive spin up? Can you hear any irregular noises such as a clicking?

    Do you have any files on this hard drive that are NOT backed up elsewhere?
     
  4. S3CR3T thread starter macrumors newbie

    S3CR3T

    Joined:
    May 14, 2017
    #4
    Thank you for taking the time to respond with some helpful tips. I did try these and to no avail. Eventually, I got access to another computer and used it to repair the drive. It would not repair! However I scoured the internet and used a ghetto/dangerous method of re-repairing the drive until it stopped not repairing. Sounds crazy, but it worked. I went and bought another drive immediately and I am now transferring the data. There wasn't any "clicking", but there was an odd whirring sound that happened every so often. Needless to say I think the drive is a goner pretty soon.
     
  5. snailfart, May 26, 2017
    Last edited: May 26, 2017

    snailfart macrumors newbie

    snailfart

    Joined:
    May 25, 2017
    #5
    having the same issue, except my computer started having issues after the 10.12.4 update (working flawlessly before that for 2 years) so what did you end up doing?
     
  6. S3CR3T thread starter macrumors newbie

    S3CR3T

    Joined:
    May 14, 2017
    #6
    Not sure I can recommend this in good fatih, but it worked for me... I repaired the drive over and over ignoring the error could not repair drive message (I did this about 14 times). Then voila it repaired on the 14th try and loaded all my files. Then I just dumped them onto a new hard drive and all my problems went away. My computer even started running faster.
     
  7. snailfart macrumors newbie

    snailfart

    Joined:
    May 25, 2017
    #7
    thanks i'll give 14 times a try
     
  8. S3CR3T thread starter macrumors newbie

    S3CR3T

    Joined:
    May 14, 2017
    #8
    Good luck. Also, while you are repairing multiple times, make sure it is fully attempting to repair. It should take a few seconds (5-10) before saying error. If it says ERROR immediately then it is defaulting to ERROR and not even trying.

    Be patient too. The final attempt that fixed my hard drive took about 15-20 minutes to repair my files/harddrive.
     

Share This Page