external hard drive not mounting

Discussion in 'MacBook' started by chewthruthesero, Dec 19, 2008.

  1. chewthruthesero macrumors newbie

    Joined:
    Dec 19, 2008
    #1
    hey guys

    i have an external seagate 1tb hard drive that was working fine until it got unplugged without being ejected first. now i cant get it to mount. when it gets plugged in it spins up and the light comes on as normal, however it dosnt show up on the desktop. if i go into disc utility it shows up there and i can use repair disc, when i repair it it goes through its motions and says that the disc had no errors. but if i click mount disc it says that the disc cannot be mounted and to try using first aid on it first. but using the first aid says that the disc had no errors.

    i am wondering if anyone can help me with this issue because after doing some research i cant see anyone who has had a similar problem.

    when i click info for the external drive this is what i get:

    Name : External Drive
    Type : Volume

    Disk Identifier : disk1s3
    Mount Point : Not mounted
    File System : Mac OS Extended (Journaled)
    Connection Bus : USB
    Device Tree : /PCI0@0/EHC1@4,1/@3:3
    Writable : Yes
    Universal Unique Identifier : 1376E9F2-2B4D-3374-8CFC-181131D1227B
    Capacity : 931.4 GB (1,000,070,627,328 Bytes)
    Owners Enabled : No
    Can Turn Owners Off : Yes
    Can Be Formatted : Yes
    Bootable : Yes
    Supports Journaling : Yes
    Journaled : No
    Disk Number : 1
    Partition Number : 3
     
  2. pyramis macrumors member

    Joined:
    Dec 2, 2008
    Location:
    Palo Alto, CA
    #2
    Mount it on another computer

    Have you tested it to see if you can mount it on a different computer? Then you'd know if the problem is with the drive itself or something stuck on your Mac due to the sudden disconnect.

    If it works on another computer, bring it back to your Mac and try logging in under a different user account (create a new one, if need be), and see if it mounts. Again, this will help narrow down where the problem lies.
     
  3. chewthruthesero thread starter macrumors newbie

    Joined:
    Dec 19, 2008
    #3
    yeah i tried it on my imac aswell, same thing. my macbook runs leopard and the imac runs tiger.
     
  4. pyramis macrumors member

    Joined:
    Dec 2, 2008
    Location:
    Palo Alto, CA
    #4
    Hmm... I know I've seen other forum posts here or at Apple Support about people with externals that show up in Disk Utility but won't mount. Maybe some research will turn up a clue. Perhaps there are other software tools that could help. Maybe something like SuperDuper would be able to read it so you could at least copy off your data and reformat (as a last resort)?
     
  5. RubenN macrumors newbie

    Joined:
    Dec 21, 2008
    #5
    I have the same problem with my external hard drive.. Wierd thing is, it mounts fine on my white macbook and my pc, but on my new alu mac it only appears in disk utility, same as mentioned in this post. It won't mount in a alu macbook pro either. It seems to me it has something to do with ntfs, 'cause when I reformatted it to FAT or Mac native, it mounts fine.. I've tried to install Paragon NTFS, with no luck on my alu mac, but successfully on the white.. Wierd since both macs are running leopard with the exact same setup, all updates up to date..
     

Share This Page