External Hard Drive not readable

Discussion in 'macOS' started by Dukey, May 7, 2018.

  1. Dukey macrumors member

    Joined:
    Sep 25, 2011
    #1
    HI all,

    So I'm plugging in my external hard drive(2TB Buffalo, not portable, it draw power from a cable) to my macbook retina pro as per usual and one day I get a message stating that i "this disk in not readable by this computer" I turn it off, I change wires from firewall 800 to usb, I change the power cord and it sometimes recognizes and I had access to some of the files in the first half of the day but after trying to access constantly, it now doesn't even allow me to move any folder from the drive.
    It says "The operation can’t be completed because an unexpected error occurred (error code -8058)." or it tells me "This operation can't be completed because it is in use." The hard drive is formatted to Mac Journal extended

    I tried to do the "first aid" on disk utilities but it says it can't be done but it does recognize it. I don't want to format it right away because I'm trying to dump the files onto a new drive.

    I upgraded to high sierra and there has been a lot of buggy issues and others have had this issue with there harddrive, so I thought it was the OS until I tried to mount it on my really old mac book. I get the same message from my old mac book as I do on my retina and the old mac book is running leopard(2007 or something).

    So I can only assume the hard drive itself in dying or corrupt and wanted to know your thoughts. Any help will do thanks.
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    If it's a hardware failure, you probably can't get the data off of it without resorting to a data recovery firm -- VERY expensive.

    If it's software corruption, re-initializing (erasing) the drive -might- bring it back to health. That makes "getting at the data that was on the drive" more problematic. But it CAN be done (I've done it).

    Something to try (no promises, chances of success low):
    Power down, all the way off.
    Disconnect the drive
    Power on the Mac, let it get to the finder.
    NOW connect the external drive.
    If the finder won't "mount it"... just WAIT a while.
    Give it an hour or so. The finder and the OS will try to repair it, then mount it.
    Don't touch anything.
    Sometimes this has worked for me.
    Again, no promises.
     
  3. Dukey, May 8, 2018
    Last edited: May 9, 2018

    Dukey thread starter macrumors member

    Joined:
    Sep 25, 2011
    #3

    It's weird, when it first started to happen, I started the process of copying over files and I got about 150gigs out of it, then after that it wouldn't give me any more access.

    I actually tried what you suggested with the whole unplugging and plugging it in for an hour and it actually worked! I was able to get another 100gb out of it before it crapped out again. But it worked! I'll try that a few time and get the primary files out. Thank you.

    Do you know why the hardware if failing? Should I not use this drive anymore? I wonder what the data recovery firm uses....
     

Share This Page