External Hard Drive not Recognising on Macbook Pro

Discussion in 'MacBook Pro' started by Rustyboy, Apr 5, 2012.

  1. Rustyboy macrumors newbie

    Joined:
    Jan 16, 2010
    #1
    I recently bought an "Intenso 6002510 320GB 2.5 inch External Hard Disk Drive" from Amazon (after reading good reviews) and I've had trouble running it on my 2011 Macbook Pro (Lion). Hopefully someone can help.

    I've read through numerous forum posts on devices not being recognised, but nothing that's helped so far.

    The drive displayed as normal for the first few days that I had it, but recently it's stopped recognising on both the desktop and on disk utility.

    I've tried the drive on another PC laptop and it shows up fine. The power/use light also comes on when plugged into both laptops, so there looks to be nothing wrong with the actual drive.

    Does anyone know of any reason why this is happening? Any help would be really, really appreciated.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    I'll take a stab in the dark and suggest that lack of power to the drive might be the cause.
     
  3. Rustyboy thread starter macrumors newbie

    Joined:
    Jan 16, 2010
    #3
    Macman, thanks for the response. I don't really follow the 'lack of power' comment: the drive has no independent power source and simply plugs in to my Macbook. Perhaps I'm being really silly here.

    Sometimes the drive registers, most of the time it doesn't. Baffling to me.
     
  4. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #4

    could be the whole usb power thing thats not giving it enough juice
     
  5. ugahairydawgs macrumors 68020

    ugahairydawgs

    Joined:
    Jun 10, 2010
    #5
    Have you tried using the other USB slot on the MBP?
     
  6. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #6
    I have a coupled WD My passport drives that work great, except the cable for one of then just does not seem to carry data, so while the drive light is on, it doesn't show up on my desktop or any other device it's plugged into. Some jiggling usually fixes it, but it's clearly the cable and not the drive, so you may want to check that as well.
     
  7. hansaus32 macrumors newbie

    Joined:
    Jan 18, 2014
    #7
    Same wifi problem with Intenso Memory2Move disk.

    MacOS 10.9.1, Memory2Move (M2M) and LG Mobile.
    After installing firmware 1.1 on M2M my MBP no longer sees the M2M (and LG mobile) wifi. Have tried all the usual fixes that I've found.:mad:
     

Share This Page