external hard drive not recognized after force eject

Discussion in 'Mac Accessories' started by mckmsha, Jun 12, 2015.

  1. mckmsha macrumors newbie

    Joined:
    Jun 12, 2015
    #1
    I checked if it's hidden but it's not. It's not in the sidebar too. My external hard drive lights up and starts with a typical sound when you plug an external hard drive to a computer. If I can remember I didn't drop it or anything but I think my macbook pro automatically forced eject it. I tried plugging it on different macbook/iMacs or even PC computer but it wasn't appearing.
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    What kind of drive is it?
    Is it a USB drive?

    Back -- WAY back -- in the old days of SCSI, Apple's HDSC setup utility offered the user the ability to "write a new set of disk drivers" to a drive that was having problems.

    However, there seems to be no way to perform a similar operation with USB drives (at least not one that I'm aware of).

    If the external drive's disk drivers get corrupted through an "improper ejection" of the drive, and they won't mount the drive again afterwards, there seems no easy way to repair this.

    It's also possible that the drive's directory got corrupted during the force-eject.
    Again, this might prevent the drive from being mounted on the desktop.

    There are some apps out there that can do some disk repairs, such as:
    TechTool Pro
    and
    Drive Genius
    and a few others.

    One of them might work, but then again, you might try all of them and still be "where you are right now", with an un-mountable drive.

    In that case, you may need to go to a data recovery app (these are different from the repair apps).

    A data recovery app is designed to "work around" the directory, and go "right to the disk platters and sectors". Then, it scavenges around to find whatever data it can, attempts to re-assemble the data, and saves what it finds onto a "scratch" disk. You'll probably lose all folder hierarchies, and many (or all) file names, but you can often get the data files back this way.

    One of the best data recovery apps is ProSoft's "DataRescue".
    There is also Stellar Phoenix Data Recovery and Disk Drill.

    These applications all work the same way:
    1. You download the app in demo mode for free
    2. You run it in demo mode to scan your problem drive
    3. The app scans the drive, and presents you with a list of files that it discovers
    4. HOWEVER -- the app will only let you recover ONE file in demo mode. The purpose is to demonstrate to you that the app will work for you BEFORE you pay the registration fee.
    5. You now pay the fee, get a code and enter it, and the app goes to work on the drive and recovers whatever it can.
    You'll also need ANOTHER drive which will serve as the "scratch disk" to receive the recovered data.

    Worth trying, and get back to us.
     
  3. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #3
    One thing to try BEFORE anything else:

    Power down the Mac, all the way off.

    Have the problem external drive nearby, but UNPLUGGED.

    Power on the Mac, let it get to the finder.

    Now, RE-connect the external drive.

    It probably won't mount immediately -- BUT -- just let it "sit there a while", for maybe up to 10 minutes.

    Reason: the finder may sense that a drive has been connected but has problems, so, the Mac will try to address those problems and then mount the drive. But it takes a little time.

    Give this a chance first, before you move on to other possible resolutions.

    Important:
    If the Mac tells you that the drive is "unreadable", and asks to initialize it, DECLINE to do so at this point in time. If you do this, the only way you can get at the data will be through data recovery software!
     
  4. mckmsha thread starter macrumors newbie

    Joined:
    Jun 12, 2015
    #4

    It still doesn't appear.
     
  5. mckmsha thread starter macrumors newbie

    Joined:
    Jun 12, 2015
    #5
    it doesn't appear in any of the applications
     

Share This Page