External Hard Drive not Showing up

Discussion in 'MacBook Air' started by LNK12, Aug 14, 2013.

  1. LNK12, Aug 14, 2013
    Last edited: Aug 14, 2013

    LNK12 macrumors newbie

    Aug 14, 2013
    I currently have a relatively new Seagate Backup Plus for Mac which has worked just fine up until now. It started a few days ago when I got the popup informing me that the disk was not ejected properly, which I found odd considering when I checked, it seemed to be still plugged in. I shrugged it off, believing I might have moved it accidentally while switching positions or something like that. When I tried to use it the next day though, it would not show up on the side or on my desktop, even with my preferences checked. I thought it was a problem with the cable, but to double check I plugged it into a PC, and it was detected immediately. After ejecting it and putting it back into my MacBook, it started to work again.. only to stop not too long after. I checked the preferences on my laptop, and both of my parents PC's detect it. I'd like to fix this problem due to the fact that I have a few important files on it.

    Also, I just left it in for a little bit longer, and a notification popped up saying something about the disk not being readable by my laptop.
  2. Cave Man macrumors 604

    Cave Man

    I'd launch Disk Utility and see how the drive is initialized (e.g., HFS+, NTFS, FAT32, etc.). If it's HFS+, repair the disk using Disk Utility.
  3. LNK12 thread starter macrumors newbie

    Aug 14, 2013
    Just tried doing that, and it won't show up in Disk Utility.
  4. Cave Man macrumors 604

    Cave Man

    Sounds like it has failed and needs to be sent in to Seagate.

    As a rule, I never buy canned (preassembled) drives, but instead buy enclosures and hard drives separately, then assemble them myself. The reason is most external drive failures are a result of the enclosure's controller and not the hard drive. If you buy a canned drive, you cannot open it to pull the hard drive because it voids the warranty.
  5. silvershamrock macrumors member

    Aug 1, 2013
    Edmonton, AB
    I had a similar problem with a WD drive recently. The drive was sending up error messages saying that it was not disconnected properly even though it hadn't been disconnected at all.

    It turned out to be a flaw in the USB cable. I had the drive replaced, and the replacement works just fine.

Share This Page