External Hard Drive problem

Discussion in 'Mac Accessories' started by dvince2, Dec 13, 2007.

  1. dvince2 macrumors 6502

    dvince2

    Joined:
    Mar 6, 2007
    Location:
    Canada
    #1
    Hey everyone.
    I just went out and got an external USB case for my 120GB Hard drive. Followed the instructions that came with it, plugged it in... nothing happens.

    When I look in device manager, it sees something attached to the computer named "üjÑPKT9ú=", but not what it is supposed to be.
    I also tried to use it under Ubuntu and XP SP2, with similar results.

    I know that the drive itself is good ( I tested it in my PC ), so I'm not sure if the case is bad, or if I've done something wrong?

    Any suggestions? Is there a special order I'm supposed to connect things together? Should I get another case?

    Thanks!
     
  2. nep61 macrumors 6502

    Joined:
    May 17, 2007
    #2
    Leopard Doesn't like USB

    Yup me too....

    I had removed my Powerbook G4's 80GB hard drive and replaced it with a 100GB 7200rpm drive...:) bought a USB case for my Notebook drive, and it had ALWAYS worked perfectly... with Tiger 10.4, that is....

    I've had similar issues to the ones you described after upgrading to Leopard... All FireWire 400 & 800 drives work fine with Leopard, the USBs ... Not so much....:rolleyes:

    I have also noticed that IF the USB drive DOES mount onto the desktop, copying to or from the USB drive is hopeless. :confused: the copy window will show the blue sideways barber pole for 2 minutes (forever !!) and then begin to copy... VERY SLOWLY... after about 50-60MB of copying, an erroe message pops up... frustrating to say the least...

    Anyone else with USB issues???
     

Share This Page