External Hard Drive Problem

Discussion in 'Mac Apps and Mac App Store' started by mightyfifi, Sep 19, 2008.

  1. mightyfifi macrumors newbie

    Joined:
    Jul 27, 2008
    #1
    I have an Iomega UltraMax 750Gb External Hard Drive set up to back up my MacBook Pro. Time Machine uses this hard drive perfectly with no problems. However whenever I want to use the drive to move files around with XP the drive does not show up in my computer. XP recognizes the connection of the hard drive and shows the name of the hard drive connected to the computer when you look at the USB BUSes but still it is not in My Computer. I have everything up to date. I have even partitioned the External Hard Drive so part of it wasn't even touched by Time Machine. Is this a problem with Time Machine formatting my external hard drive to work only for Mac or this a problem with XP.

    -fifi
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    XP can't read a Mac formatted disk (HFS+), so you have two choices. You can install MacDrive in XP to be able to read that disk, or you can reformat the second partition as FAT32, which both systems can read and write. I'd probably recommend the second option, it'll be easier and more reliable overall.

    jW
     
  3. mightyfifi thread starter macrumors newbie

    Joined:
    Jul 27, 2008
    #3
    could you explain how I would go about doing the second option. it does seem simple though i want to make sure i do it the right way. thanks for the quick response.

    -fifi
     
  4. webs1 macrumors member

    Joined:
    Aug 14, 2008
    #4
    This works on Leopard, and should be similar on other version . . .

    Open Disk Utility which is in Applications>Utilities.

    Select the hard disk from the left hand side.

    On the right side, click on the PARTITION tab.

    Click the plus sign to add a new partition.

    When you click on the new partition, you will have the option to name the partition and to select it's format.

    Click on the drop down menu next to "FORMAT" and you should be able to select FAT32.
     
  5. xpietrox macrumors newbie

    Joined:
    Jan 14, 2009
    #5
    mightyfifi, have you used the firewire 800 port on your iomega ultramax?

    I've had 2 of them and I haven't gotten either of them to work. Iomega support couldn't help me, they said it must be an apple driver thing. But it's hard to believe this hasn't come up before.
     
  6. mightyfifi thread starter macrumors newbie

    Joined:
    Jul 27, 2008
    #6
    yes I have. I works perfectly with my mac and time machine so there is no problem with the ports. through looking at the ports with XP the computer does recognize that its there and it even recognizes the name of the hard drive, however it still does not show up in my computer or allow any data transported to it. and that is after I partitioned it to have a FAT32 format.

    whats funny though is that it won't work with the firewire 400 connect or a usb connection.

    -fifi
     
  7. webs1 macrumors member

    Joined:
    Aug 14, 2008
    #7
    Even though it is now partitioned as FAT32, you may still need to complete a few steps in XP. Remember to be very careful in your selections, so you don't accidentally erase anything.

    OK . .

    -In XP, right click on My Computer, then select Manage
    -On the left hand side, Click on Disk Management, which is under the Storage section
    -On the right hand side, look for your Hard Disk and the Fat32 partition (bottom pane)
    -Right click on the partition and select Format (make sure you are in the correct partition)

    Make sure the disk is also Active, and hopefully that will solve your problem.
     

Share This Page