External hard drive spins up, but won't mount. Help?

Discussion in 'Mac Accessories' started by dopey220, Feb 25, 2009.

  1. dopey220 macrumors 6502

    dopey220

    Joined:
    Jul 19, 2006
    #1
    So, I have a LaCie 320 GB external hdd (USB 2.0) that worked perfectly until last night. Now it won't mount when I connect it to my computer, nor can I see it in Disk Utility. Disk Warrior can't see it either. I tried connecting it to my roommate's MBP with no luck.

    It spins up just fine and doesn't make any clicking noises or anything like that, so I feel like there might just be some hope yet; I'm thinking it might just be a faulty USB cable or something, but I don't have a spare one to try it with.

    My neighbor is a big techie, so I'm probably going to give him a call later, but I was hoping you guys might have some other suggestions before I bug him with it. Thanks.
     
  2. harry454 macrumors 6502

    Joined:
    Sep 13, 2007
    #2
    did you try restarting your mac with it connect? Also try booting disk utility from the install disc and see if it picks it up, also see if it picks up in another computer if it doesnt your HD has faulty connectors or is just dead
     
  3. Pixellated macrumors 65816

    Joined:
    Apr 1, 2008
    #3
    Sounds like a dead HD. They still spin up. Is there any activity? Clicking/Blue light flashing?
     
  4. dopey220 thread starter macrumors 6502

    dopey220

    Joined:
    Jul 19, 2006
    #4
    All activity appears to be normal, as far as lights and sounds go. Just doesn't mount.
     
  5. QueenBitch macrumors newbie

    Joined:
    Feb 27, 2009
    #5
    im having the exact same problem. i bought a 1TB drive just 5 days ago nd used it last night. now nothing. i did a dodgy dismount last night but come on, these things can survive that once in a while surely. a minute ago it was flashing alot then the access light turned off, but now the access light is solid. my poor macbook is whirring away like crazy trying to deal with it, but no evidence of the drive. if i open disk utility it says "gathering disk information" indefinitely and won't close. if i yank the drive disk utility will calm down and show my internal drive. what the hell?

    one note. i copied a folder over and all the contents ended up corrupted. i deleted it but it wouldn't leave the recycle bin. no matter what. this wasn't a problem at all but i wonder if having some corrupt stuff on there has killed it. which isn't fair because it working just fine until yesterday.
     
  6. QueenBitch macrumors newbie

    Joined:
    Feb 27, 2009
    #6
    i took it back today and they won't exchange it. they plugged it into their windows machine and all the folders showed up straight away. im going to try plugging it into my friends windows machine too. can someone please help me out here. do i have to reset something in my mcbook's usb ports? please please help
     
  7. Winni macrumors 68030

    Winni

    Joined:
    Oct 15, 2008
    Location:
    Germany.
    #7
    Try booting from your OS X installation DVD, then launch its Disk Utility (you can start it from the menu bar; just don't start the OS X installation itself). If the USB drive is visible there, let Disk Utility repair the disk and its permissions. After that, reboot to your regular OS X installation and see if the disk re-appears.

    You can also try rebooting your Mac with the drive being physically disconnected from your Mac. Then shutdown OS X, plug in the drive and startup your Mac again.

    I've had similar problems with FireWire and USB disks in the past and the fiddling described above usually helped.
     
  8. QueenBitch macrumors newbie

    Joined:
    Feb 27, 2009
    #8
    thanks for the reply. i did both those things and still nothing. i ran disk utility from the install disk and it did the same thing. "gathering information" until the end of time. when i pull the drive out it shows in disk utility, but never when its connected.
     
  9. QueenBitch macrumors newbie

    Joined:
    Feb 27, 2009
    #9
    latest in this exciting narrative. i managed to get the drive to show up in disk utility. by forcing fsck_msdos to quit from activity monitor. now im running verify and repair, fsck_msdos is taking up 100% of the computers power. its been going for few hours now. no sign of stopping. should i give up?
     
  10. mmichalak macrumors newbie

    Joined:
    Mar 28, 2009
    #10
    Same Problem - Solution!

    Hi there,

    I know this is an old thread but... I had the same problem with my external Seagate (don't remember the model, couple of years old), after removing it without unmounting it..

    I would connect it, it would spin up, but it would never mount... As you say, it would work perfectly under Windows on a different machine...

    Be amazed to read the solution in my case:
    (drums rolling....)

    Run VMWare, Windows Vista... Take control of the USB port under VMWare, disk appears in Vista, disable USB under VMWare..... disk now appears in MacOS....
    that simple.... hours of agony and sweating, (thousands of pictures and mp3s on that disk), and problem solved by the help of Windows:confused:

    :apple: 'It just works'....
     
  11. djcheckone macrumors newbie

    Joined:
    Apr 7, 2009
    #11
    wait one min buddy!!!!

    you mean to tell me that you may have figured out something huge and you post with no detail... do tell ... do tell.. vmware what? There website offers lots of things and I don't want to pick them all even though I am super desperate right now..

    I just finished crying about my drive and I saw your post, and my mood changed to hopeful..

    I would like to know what to do so bad right now... I'm going through the same problems with a drive that dropped and disconnected from my computer. Now its doesn't work.

    so, whats the science boss?
    :eek:
     
  12. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #12
    djcheckone, what mmichalak has said is by no means a solution to every problem. it is simply a solution to his problems, and maybe a few others who have a similarly configured computer..

    VMWare and Parallels can both mount drives automatically if they are running (they are virtual machines if you did not know) - this is an isolated case though.

    what i would suggest is go to

    Apps->Disk Utility (the same application that you use to check file Permissions)

    look on the left hand side and see if your drive pops up there at all. if you can, take a screen shot (by pressing :apple: + Shift + 4, then dragging the area you want to take a picture of - it will be saved to the Desktop by default) and post that picture here. maybe we can help.
     
  13. Cave Man macrumors 604

    Cave Man

    #13
    Mounting issues like the OPs usually are a controller failure. The drive is likely fine, but the controller has crapped out.
     
  14. OldMike macrumors 6502

    Joined:
    Mar 3, 2009
    Location:
    Dallas, TX
    #14
    I agree with this statement. I have had many external drives fail on me, with the internal disk still being good and usable. I would suggest getting an external enclosure or one of those 2.5" & 3.5" SATA hard drive docks. Pop the drive in and you might be pleasantly surprised to find that the drive is ok.

    A scare like this, is a good way to become compulsive about backing up all of your data!
     
  15. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #15
    i have had this happen many times, i find that a restart (cold restart) normally fixes the issue..
     
  16. biggddogg21 macrumors newbie

    Joined:
    Apr 8, 2009
    #16
    Picture

    PIC
     

    Attached Files:

  17. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #17
    wow your running Tiger, nice!

    ok so see the "D Ellis HD" (the name of your partition), that appears to be not mounting. click on "D Ellis HD", go up to the top of the window and click the "Mount" button....

    hopefully that will make it work!
     
  18. mmichalak macrumors newbie

    Joined:
    Mar 28, 2009
    #18
    Hello there,

    now comes the reply from the boss :p

    As other people have said, this may not be the solution for everybody, there are a million reasons why this can happen... Hopefully, your drive works fine, even though you dropped it :eek:

    VMWare is a software you can use to run different operating systems from within OS X. Apart form VMWare itself you would also need another operating system.... In my case, I had an original version of Vista (student licence, legally downloaded).... VMware can be downloaded and used for free for a certain period (I do not have experience with Parallels...).

    Things that I also tried and failed:
    a) resetting PRAM during reboot
    b) removing battery for 20 mins (I had seen this somewhere)
    c) rebooting

    My controller was definitely not damaged, since my hard disk was working fine on my pc as well... I have to say I was quite surprised with this one, I do not know what the problem was, but in my case this was the fix.

    If you happen to have bootcamp installed with another operating system try to boot into that and see what happens.... Just to check that your disk is fine, try to plug it in a different computer, a friend's computer for example...

    I hope it works out ok for you, let us know how it goes...
     
  19. biggddogg21 macrumors newbie

    Joined:
    Apr 8, 2009
    #19
    If Only it were that easy...

    If Only it were that easy...yep I've tried that before in the past. Will not mount but it will recognize it in Disk Utility.
     
  20. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #20
    well then you would have been in a bit of trouble!!!! not sure what you would do then...
     
  21. darcyf macrumors 6502

    darcyf

    Joined:
    Apr 25, 2011
    Location:
    Toronto, ON
    #21
    Just to add to the solution pool, I had an external hard drive that just yesterday wouldn't mount, and like in the original poster's situation the drive seemed fine, no weird noises, spun up as usual. Just would not mount.

    Took it out of the enclosure and put it in a Mac Pro and it showed up like any other drive, with all my files in tact.

    So in a situation like that where the drive seems healthy but it won't mount, it may just be the enclosure has failed and the drive is fine.
     
  22. Cave Man macrumors 604

    Cave Man

    #22
    And this is why I never buy canned drives - if there's a problem, you can't disassemble them to resolve it without voiding the warranty. I always buy my enclosures and hard drives separately.

    Drives: Segate, Samsung or Hitachi
    Enclosures: OWC, Rosewill or Macally
     
  23. LifeboatB macrumors newbie

    Joined:
    May 26, 2015
    #23
    I realize this thread is old, but just in case it helps anyone else: I had this same problem, and it turned out to be the cord. I just borrowed a cord from another external drive, hooked it on the problematic one, and the macbook pro mounted it fine.
     
  24. dakwar macrumors 6502

    Joined:
    Nov 2, 2010
    #24
    In case this helps anyone out there:

    I have the same problem with my MacBookPro12,1 running 10.11.5. WD 1TB USB3 portable external drive does not mount.
    I tried using a different cable - still doesn't mount.
    I tried the same cable but plugged it into another MacBookPro12,1 running 10.11.5 - mounts just fine.
    I tried it again on the original mac - does not mount.
    I can't restart my mac atm - will do a restart over the weekend.
     

Share This Page