!!External Hard Drive Stopped Showing Files!!

Discussion in 'Mac Basics and Help' started by urodiculis, Sep 23, 2009.

  1. urodiculis macrumors newbie

    Joined:
    Dec 28, 2008
    #1
    Recently I just converted my old PC's 250gb Hard drive into an external drive. In the beginning everything worked fine. Though I could only read the files from it on my mac, I was fine with that because there was so much old music and pictures that I wanted to get off of it. There happened to be one particular picture that I couldn't find searching through the HDD with my mac, so I thought maybe i would be able to find if I looked for it through a windows system. So I then plugged the external into my Windows laptop. After failing to find the picture on the PC, I plugged the hard drive back into my mac, but for some reason it's not showing the files. The hard drive is being found, but when i click on them in the finder no files show! The drive is not erased because the capacity and amount free is still the same. And to put the icing on the cake when I plugged the drive back into my PC a message comes up that says "The request could not be performed because of an I/O device error"

    HELP!!!!!!!


    Thanks
     
  2. urodiculis thread starter macrumors newbie

    Joined:
    Dec 28, 2008
    #3
    The interesting thing is that my drive is partitioned into one 150gb segment and another 100gb segment. I just discovered today that the 100gb segment is still readable but for some reason i can't get to the other part. Is this good news?
     

Share This Page