External Hard Drive Troubles

Discussion in 'Mac Accessories' started by cambookpro, Nov 17, 2014.

  1. cambookpro macrumors 603

    cambookpro

    Joined:
    Feb 3, 2010
    Location:
    United Kingdom
    #1
    Hi,

    At the moment, I use a 2TB WD My Passport Studio for my Time Machine backups. However, today I received an error when trying to back up saying the disk was read only. I unplugged it and plugged it back in, but now it doesn't even mount in Finder.

    (It has a constant blinking white LED if that's Western Digital's way of indicating anything)

    I went in to Disk Utility and tried to verify the volume, but it spat out an error saying I needed to repair it. I tried that, and it came out with 'Disk Utility could not repair the disk. Back up as many as your files as possible, reformat the disk, and restore you backed up files.'

    I then went to erase it, but it comes up with an error saying 'Disk Erase failed with the error: Couldn't unmount disk.' I've tried on two Macs with two different cables, so I think it must be something to do with the disk. I tried to add it to the Spotlight privacy settings incase it was indexing it when trying to unmount, but it doesn't appear in Finder (only DU) so I wasn't able to.

    The disk, according to Disk Utility, is fine, but the volume isn't and spits out a few errors, none of which look good.

    Is my disk dying/dead? :(

    A couple of questions:
    1) Why does DU, when repairing the disk, seem fine when you click on the actual disk, but not the volume?

    2) If I need to replace it, are there actually any 2TB FW800 drives still in production? The WD one I have currently is out of stock everywhere!


    Thanks.
     
  2. thedeske macrumors 6502a

    Joined:
    Feb 17, 2013
    #2
    Sounds like it is. Does that passport have USB or is it Firewire only?
     
  3. cambookpro thread starter macrumors 603

    cambookpro

    Joined:
    Feb 3, 2010
    Location:
    United Kingdom
    #3

    It's USB and FW, though I've tried it with both with no difference in result.
     
  4. cambookpro thread starter macrumors 603

    cambookpro

    Joined:
    Feb 3, 2010
    Location:
    United Kingdom
    #4
    I've downloaded WD's own drive utilities and erased it, and it seems to be working OK now.

    Not sure if it'll suddenly stop again tomorrow, but touch wood it remains working.
     
  5. cambookpro thread starter macrumors 603

    cambookpro

    Joined:
    Feb 3, 2010
    Location:
    United Kingdom
    #5
    It seems to be backing up fine and Disk Utility now reports no errors when you verify the disk. How strange, I wonder what was wrong.
     
  6. TechpumpkinWD macrumors newbie

    Joined:
    Sep 18, 2014
    #6
    Hi there,
    It could have been the partition being damaged. It's great that reformatting solve the issue, but it's also a good idea to run the extended WD test on the HDD if you haven't yet. Just to be on the safe side.
     
  7. arbrx macrumors newbie

    Joined:
    Mar 19, 2014
    #7
    I own a similar WD drive that didn't mount properly on Yosemite - I updated the firmware (9-2014) on Western Digital's website, then went the Disk Utility to Repair the drive (that did not mount but was visible in Disk Utility). It didn't complete and seemed to time out on Yosemite - I hit stop and it mounted a couple seconds later. For what it's worth, wanted to pass along. Seems to be working fine again today.
     
  8. cgrootes macrumors newbie

    Joined:
    Dec 12, 2014
    #8
    Lacie Hard Drive does not show up in Finder but appears in Disk Utility where its nam

    Sorry to post this here but i need some desperate help!

    When I ran the "Repair Disk" function in Disk Utility the 1TB TOSHIBA MK1059GSM Media (Which I assume is my Lacie) shows that the "The partition map appears to be OK". When I plug in the Lacie it doesn't make any wierd needle noises and it flashes consistently, like it always has!

    Underneath the 1TB TOSHIBA MK1059GSM Media is another orange Drive where it says "Time Machine Backups". These seem to be corrupt. When I ran Repair Disk on it it says "Error: Disk Utility Can't repair the disk... disk, and restore your backed-up files".

    That is fine I'm not trying to recover my backups but instead a folder called "Pictures" that has around 40GBs of my University photos on there (therefore super sentimental).

    I cant seem to locate that folder on Disk Utility or on the Finder, but would really appreciate some help on how to get these pics back!!

    Many many many thanks in advance and help is really appreciated!
     
  9. rigormortis, Dec 12, 2014
    Last edited: Dec 12, 2014

    rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #9
    Western Digital and Seagate and most other hard disk drive diagnostics cannot really check a hard disk that is in a usb enclosure. the usb to sata adapter is a BRIDGE. it has own firmware and cannot pass s.m.a.r.t. failures to the host operating system


    i like disk warrior, it will help in these situations where disk utility will fail

    without checking the actual smart sensor a diagnostic utility can just do a basic disk test


    I've heard horror stores about trying to run disk utility on time machine and time capsules and it can do some serious damage to your bundle file


    i am sorry

    your test did nothing

    the problem is that s.m.a.r.t. is not supported in external hard disk enclosures.
    its the s.m.a.r.t. sensor that judges if your drive has actually failed or if just needs to be erased. hard disk companies require a smart failure code or a clicking drive before they will do a warranty replacement


    if you really want to check a hard disk is okay and you want to run a hard disk companies diagnostics ( to see if the drive is in warranty or not ) you must remove the disk drive from the enclosure and connect it to a real SATA port that is internal to a computer.

    i apologize but that is just the way it works..

    you can go to system under about this mac, and clearly see that it says " smart not supported " on every external hard drive you have. and it will say "verified" on the internal

    ill try some diagnostics i have to double check this post later
     
  10. cambookpro thread starter macrumors 603

    cambookpro

    Joined:
    Feb 3, 2010
    Location:
    United Kingdom
    #10
    I ran that soon after, nothing untoward appeared. It's been working fine now for almost a month, so I think it may have just been the partition.
     
  11. hologram macrumors 6502

    Joined:
    May 12, 2007
    #11
    If you can't get them any other way, you might try PhotoRescue
     

Share This Page