External Hard Drive (USB3.0) only works through USB2.0 hub

Discussion in 'iOS 7' started by Danthesaxman, Oct 23, 2013.

  1. Danthesaxman macrumors newbie

    Jun 3, 2012
    For quite a while now some of my external hard drives have not worked when directly plugged into my Macbook Pro (Mid 2012 running 10.8.5). They work perfectly when plugged into a USB hub and then into the macbook but not directly to the mac. Standard small USB flash drives work fine straight in to the macbook, the real problem appears to be USB 3.0 hard drives. These will not show up on desktop or disk utility unless I plug them in via a USB hub (which is USB2.0). The hard drive format doesn't seem to be important, currently my Mac OS Extended Time Machine backup HD is only working through USB hub, and my MyPassport WD external drive is NTFS and hasn't worked directly into the Mac for a while now.

    Normally this is not a big issue, but when I am on the go it is useless to carry a USB hub around along with a MyPassport hard drive! In addition, there are times, such as when backing up, that I want the speeds offered by USB3.0 from my macbook to my hard drive.

    What could be the problem? I run NTFS for Mac OSX, not sure if that would cause an issue with the direct connection.
    Please help, this one is grinding my gears!

  2. Afflictare macrumors newbie


    Aug 20, 2013
    It might help if you posted this in the right forum, not under iOS 7.

Share This Page