External hard drive will not mount

Discussion in 'macOS' started by arihs, May 7, 2011.

  1. arihs, May 7, 2011
    Last edited: May 7, 2011

    arihs macrumors newbie

    Joined:
    Aug 4, 2010
    #1
    Hi all,
    Hope I have the right place for this.
    I got the new MBP today and after setting it up I realized my external HDD wasn't showing up. It was recognized (showed up in disk utility) but would not mount. It's definitely not a problem with the HDD itself-- tried it on other computers (both mac and windows), and there was no problem, so I'm thinking it's to do with Snow Leopard. (My previous macbook was from 2008) Formatting the HDD is not an option at this point... does anyone have any tips/insight?
    Thanks.

    Edit: Not sure if this is related (seems like it is though), but I can't boot into Windows now and the bootcamp partition has gone the same way as my HDD... it shows up in disk utility, but is greyed out. It was showing up before, but went all funny after I had to restart the computer after installing bootcamp software (from OSX install disk). Seems like some type of software problem to me? Regardless this is very frustrating and annoying... any help is appreciated.
     
  2. discounteggroll macrumors 6502

    discounteggroll

    Joined:
    Aug 6, 2006
    Location:
    Greenwich, CT
    #2
    did you try manually mounting it from disk util or just wait for it to show up on the desktop?
     
  3. arihs thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #3
    I think I solved my problem (downloaded some new Tuxera NTFS software), but I've developed another one-- I got my HDD/Bootcamp to show up but now everytime I try to boot into Windows I get a black screen for a few seconds, it flickers, and then goes back to the grey screen again (I have to hold option to get out of the loop). It sounds like the internal HDD is trying but can't "connect"--another software problem maybe?
     

Share This Page