external hard drive won't eject

Discussion in 'Mac Basics and Help' started by aureiden, Feb 14, 2009.

  1. aureiden macrumors member

    aureiden

    Joined:
    Mar 7, 2007
    Location:
    USA
    #1
    Supposedly, the external is in use and cannot be ejected, but i don't think it's in use. I've only recently been encountering this problem, and i have no idea why. I've tried quitting every application, but it still claims to be in use. Any ideas?
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Try Finder. Control-option-click on the Finder icon and select Relaunch. It could be that Spotlight is indexing the drive, too.
     
  3. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #3
    There is a cool little free utility called "What's Keeping Me?" that will tell you exactly what is hanging it up. You can download it here- and I pretty much guarantee you will slap your forehead when it shows you the cause of the delay. I know I have every time I have had to use it!;)
     
  4. spellflower macrumors regular

    Joined:
    Jun 7, 2005
    #4
    Okay, old thread, but it's what came up when I started having this problem.

    Thanks, sickmacdoc, that program let me know that my drive was still being indexed by Spotlight.

    My question is, why the heck can't Apple change the message from "the drive can't be ejected because it is in use" to "Spotlight is still indexing your drive. If you really need to eject it, click ok to stop indexing. Otherwise just wait a few minutes."?
     
  5. bpetruzzo macrumors regular

    Joined:
    Oct 22, 2005
    #5
    It's about damn time! I don't know why no one else has recommended that application. It works like a charm!

    But I have to agree. If it's a process, like Spotlight, or in my case ClamX (which I didn't even know would be running in the background like this), why can't MacOS say something like, "_______ is accessing files on the drive you are trying to disconnect. To abort this process and eject click ok, or wait a few minutes and try again."?

    Wouldn't it be safer to abort a process than hard ejecting a drive?
     
  6. guitarteachjc macrumors newbie

    Joined:
    Dec 5, 2010
  7. Zandiman macrumors newbie

    Joined:
    Jan 17, 2010
    #7
    Great Fix

    Thank you so much for this fix. It is the only fix I found which allows me to eject my USB drive safely AND THE easiest. Great job.
     
  8. Pageajj10 macrumors newbie

    Joined:
    May 6, 2013
    #8
    Spotlight indexes immediately!

    Hi all. The spotlight index issue seems to be what's holding me up. I downloaded What's Keeping Me (great program, super easy to use), and sure enough there were dozens of spotlight processes going on. I quit them all, but each time I try to eject my HD, I get the same "One or more programs may be using..." error message, and when I do another WKM search, sure enough there's one spotlight process. Quitting it and trying again just has the same result. I've also tried re-launching finder, with no success. I hate doing the force eject, especially because more than once it's failed to recognize the drive after that. Both times, disk utility has managed to repair it, but I don't want to risk that again.
     
  9. jhencken macrumors newbie

    Joined:
    Jul 17, 2011
    Location:
    Watertown, MA
    #9
    --- Post Merged, Jul 2, 2017 ---
    I'm afraid the answer to all questions beginning with "why the heck can't Apple..." have the same answer: Give up. It's an eternal mystery.
     
  10. AlternaAngel macrumors newbie

    AlternaAngel

    Joined:
    Sep 2, 2017
    #10
    I downloaded it, but what do I type in? I have the same problem that my external hard drive won't eject. Then what do I click after? Sorry, this is new to me.
     
  11. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #11
    ?
    The What's... app tells you on the opening screen:
    So, you would type in the name the external volume that won't eject.
    Or - you can just drag the disk on the app window, which will do that same thing, but much quicker.
    Or, just select the name of that disk in the enhanced features drawer.
    I can almost say "easy-peasy", but I won't do that. :D
     
  12. AlternaAngel macrumors newbie

    AlternaAngel

    Joined:
    Sep 2, 2017
    #12
    Yeah I got all that, but when I choose something to quit, it asks me where and won't let me choose my harddrive, so I can't get it to work
     
  13. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #13
    Do you mean that the hard drive does not appear in the Enhanced Features drawer?
    You don't need that, if the hard drive is still mounted on your desktop.
    And, if it is NOT mounted, then all you should need to do is unplug (or turn off) the external hard drive.

    After saying that, I looked at the What's Keeping Me app some more. It's pretty sensitive to being the active app. I had to click in each area on that app window before something that I want to quit or eject would be available.
    And, it looks like the app won't do anything unless there is actually a problem --- that is, an app that won't quit, or a drive that won't unmount/eject.

    Try using your Force-quit window by choosing each app to force quit each app, one at a time, until only the Finder is left, then try force-quitting the Finder, too.
    Try to eject your disk, until you see an error message that your disk can't be ejected.
    Be sure to close that message window, too.
    THEN, run the What's Keeping Me app at that time. Should be simple now to see what is truly holding your drive hostage --- maybe.
     

Share This Page