External Hard Drive Won't Erase. Help with Time Machine

Discussion in 'macOS' started by kerks28, Sep 1, 2009.

  1. kerks28 macrumors newbie

    Joined:
    Apr 28, 2009
    #1
    I am using a macbook with an Intel Core 2 Duo (about two years old) and I am running leopard (10.5.8).

    I have been using a Western Digital 250GB External Hard Drive with a firewire connection to utilize Time Machine for the past 6 months. All was going reasonably well until recently. (It would occasionally get stuck backing up and I would have to restart my computer and then backup again, but otherwise ok)

    Last week I turned my computer on and it didn't recognize the drive. It gave me the "Initialize" "Ignore" option screen. I tried everything before I tried erasing it, but eventually I decided to lose all of that backed up data and just erase the drive and start from scratch. (I backed up on a different drive prior to trying this.)

    Anyway, now when I go into Disk Utility and click on the Erase tab and then try to erase the drive (doesn't matter which erase option I choose) it says it is unable to erase the drive. If it is plugged in w/the Firewire cable then it gives me an "Invalid Argument" error. If it is plugged in with the USB cable, it gives me a input/output failure error.

    Does anyone know if I can fix this drive? Any ideas as to what may have caused the problem in the 1st place. Months ago I accidently unplugged the drive without ejecting, but it worked for for a long time after that.
     
  2. MKSinSA macrumors regular

    MKSinSA

    Joined:
    Aug 1, 2009
    Location:
    Alamo City, Lone Star State
    #2
    WD has a troubleshooting guide for HDs that OS X no longer recognizes. Gives some hope for error-filled drives that might still be operational.

    HTH ... Good luck! :cool:
     

Share This Page