External hard drives - sometimes mount, sometimes don't. Ongoing problem.

Discussion in 'macOS' started by shoelessone, Oct 21, 2007.

  1. shoelessone macrumors 6502

    Joined:
    Jul 17, 2007
    #1
    Hi, I have a MacBook Pro 2.2ghz blah blah blah, with the latest version of tiger installed (all updates, etc).

    I have two external HDs hooked up to an external USB 2.0 hub.

    Here is the thing: OSX sometimes mounts the external drives, sometimes doesn't. It seems, to me, to be almost 100% random. At the moment my 250gb NTSF drive is mounted. I had to restart because my MBP froze up (for the second time this week btw, I also had a kernal panick. My GF just commented, "you new laptop freezes more than my computer!" - she has an old XP Pro machine I built for her. I feel great). Anyway, before I restarted both my drives were working properly, one 250gb NTSF and one 250gb FAT32. I restarted, and only the NTSF drive came back.

    The thing is the drives keep spinning up, they are on, spinning, blah blah, just not mounted.

    So, of course I tried using disk utility to mount the drive, but when that happens I get "error messages", I believe disk utility recommend I run disk recovery but, that isn't an option or it didn't do anything. No fix.

    So, I end up restarting my drives, powering them up, powering them down, sometimes for a seemingly random reason start working.

    Anyway, any thing I should know?

    Anyway, I have read about people having problems with external hard drives, but I'm wondering if there are any solutions I'm missing, etc.
     
  2. coocooforcocoap macrumors regular

    coocooforcocoap

    Joined:
    Sep 22, 2007
    Location:
    kathmandu, nepal
    #2
    same here...

    same here. i suspect it has something to do with harddrive usb board, as i have 3 drives, and two of them exibit random mount behavior while one always mounts. i plug mine direct into the usb slot, and same behavior. maybe leopard will fix...
     
  3. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #3
    I've noticed that NTFS drivers have been the cause of panics in the Santa Rosa Macbook Pro.
     
  4. mmendoza27 macrumors 6502

    Joined:
    Oct 18, 2007
    #4
    I'm kind of having some of the same problems, except mine deals with FW400 and FW800. I mount an external My Book HD and it doesn't show up on finder. It'll show up in Disk Utility, but I can never access it...

    Funny thing is, I use it all the time over my network using the AirDisk utility. Hopefully it'll be fixed with Leopard.
     
  5. shoelessone thread starter macrumors 6502

    Joined:
    Jul 17, 2007
    #5
    I'm not holding my breath. Maybe, but... Seems like something that could/should have been fixed long ago.
     

Share This Page