External hard recognized by system but doesn't show in finder

Discussion in 'MacBook Air' started by sowon, Aug 23, 2013.

  1. sowon macrumors newbie

    Joined:
    Feb 8, 2013
    #1
    Hi All ..
    I have a problem & I would appreciate help from expert users here :)

    I have an external hard disk & it was working fine with my MacBook Air (Mac OS X 10.6.8) I could carry my mac with the external hard plugged in & move to another place without it unplug..
    However lately,I noticed there are many sudden "unplug" within any move or with no move..I get the message that it was unplugged & I should have pressed "Eject" before unplugging it..at such cases,I used to plug in instantly then eject properly and it would work fine for some time later..
    Days ago,I got the message of the disk unplugged but whenever I try plug it in again..it never shows in the finder..
    however by pressing
    Apple->About this mac->More Info->USB ->
    I see this info
    Capacity: 500.07 GB (500,074,283,008 bytes)
    Removable Media: Yes
    Detachable Drive: Yes
    BSD Name: disk2
    Product ID: 0x0730
    Vendor ID: 0x1058 (Western Digital Technologies, Inc.)
    Version: 10.12
    Serial Number: 575850314143303534343733
    Speed: Up to 480 Mb/sec
    Manufacturer: Western Digital
    Location ID: 0x24100000 / 3
    Current Available (mA): 500
    Current Required (mA): 500
    Partition Map Type: MBR (Master Boot Record)
    S.M.A.R.T. status: Not Supported
    Volumes:
    AMANY:
    Capacity: 500.07 GB (500,074,219,008 bytes)
    Writable: Yes
    File System: MS-DOS
    BSD Name: disk2s1
    --------
    I tried to see if the external disk works on another pc & it worked fine..also I used another USB on my mac & it was detected in finder normally..
    I also tried Disk Utility but the external hard didn't appear there.
    --------
    Do have any suggestions for me??
    Thank you for your help
     
  2. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #2
    U have a loose USB connector or cable OR the drive's power requirement is hitting the notebook's limit.

    Given what u have already done, I would try to self-power the external or use a powered hub see what happens.
     

Share This Page