External HD error

Discussion in 'MacBook Pro' started by roarr, Sep 13, 2011.

  1. roarr macrumors newbie

    Joined:
    Sep 13, 2011
    #1
    I'm not sure if this is in the right section but I'll give it a go anyway because I need some help!

    I have a 1.5TB external hard drive and a 13i macbook pro. I've never had any problems with it until my friend just tried to use it to copy some of the stuff i have on there.

    Now whenever I try to use it it comes up with this error:

    "NTFS-3G could not mount /dev/disk1s1 at /Volumes/External 1.5TB because the following problem occurred:
    ntfs_attr_pread_i:ntfs_pread failed: input/output error
    failed to read NTFS $Bitmap: Input/output error NTFS is either inconsistent or there is a hardware fault or it's a SoftRAID/fakeRAID hardware.
    In the first case run chkdsk/f on windows then reboot windows twice.
    THe usage of the /f parameter is very important!
    If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/directory (e.g. /dev/mapper/nvidia_eahaabcc1).
    Please see the 'dmraid' documentation for more details. "


    I've had a look on some other forums and can't find out how to fix this... can anyone help?

    Thanks
     
  2. Prodo123 macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #2
    Drive corruption, most probably caused by:
    1. Drive failure
    2. Physical shock
    3. Heavy fragmentation (very unlikely)

    Like it says, go on Windows through Boot Camp and run chkdsk on it. Mac OS X is not very friendly to NTFS, which your drive uses, so you will be better off running diagnostics on the hard drive on Windows.
     

Share This Page