External HD (for Time Machine) wakes up for no apparent reason

Discussion in 'Mac mini' started by Thrash911, Apr 12, 2010.

  1. Thrash911 macrumors 6502

    Thrash911

    Joined:
    Sep 14, 2006
    Location:
    Randers, DK
    #1
    Hello forum,

    I have a Mac Mini with two external WD MyBook's attached. The drive in question, is configured for Time Machine backups every four hours. It should sleep the rest of the time. But every once in a while, it wakes. I just revs up for no reason, then after a short while it goes back to sleep. It can happen when I open a folder, open a file, click a link in the browser or some other seemingly unrelated action.

    I tried to untick the "Put the hard disk(s) to sleep when possible" to see if I then at least could get the drive to stay awake instead. This did not change the behavior at all.

    Does anybody have a clue what I can do, to get OS X to leave that drive the hell alone, other than Time Machine?? :)
     
  2. Phantom Gremlin macrumors regular

    Joined:
    Feb 10, 2010
    Location:
    Tualatin, Oregon
    #2
    me too

    I also have this problem, and haven't been able to solve it. It's f***ing annoying.

    You can see the activity by issuing the following command in terminal:

    iostat -w 60

    IIRC the wakeups happen every 15 minutes. Which is really annoying because it takes my drive 5 minutes to go to sleep.

    I think it has something to do with spotlight. The problem is that spotlight knows not to access the backup directory but it still insists on accessing the top level directory of the drive. I did some Googling and some playing around (with, IIRC, the lsof command) and that's how I determined it was spotlight.

    This might be better posted in an OS X forum, because I don't think it has anything to do specifically with an iMac.
     
  3. IJBrekke macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Long Beach, CA
    #3
    The best explanation I've seen for this is that OSX likes to have all available drives spun up and ready to go whenever you do something related to retrieving information from a drive, i.e. using Finder or Spotlight. Even though you're not accessing the back-up drive directly, the OS spins it up "just in case" you need it.

    I've tried assigning the hard drive to be exclusively for Time Machine...no difference. I've tried blocking the drive from being searched and indexed by Spotlight...no difference.

    Because spinning up the hard drive every 15 minutes causes unnecessary wear-and-tear, I've just resorted to turning it off unless I'm manually backing up. It's annoying, but it's not nearly as annoying as having the drive spin up constantly.

    In short, I haven't found a fix for this problem, mostly because I think OSX is doing it on purpose.
     
  4. Phantom Gremlin macrumors regular

    Joined:
    Feb 10, 2010
    Location:
    Tualatin, Oregon
    #4
    That certainly saves a lot of wear-and-tear. However, whenever I've turned off my external I invariably forget to turn it back on. Time Machine starts complaining after 7 days, but that really defeats the whole purpose of it.
     
  5. Ganesha macrumors regular

    Joined:
    Aug 4, 2009
    #5
    When you Mac goes to sleep mDNSResponder will set an mini-wakeup for some time later. Things like back-to-my-Mac (as an example) will request a wakeup every 2 hours so it can re-register itself with external servers.

    Try turning off wake for network access and anything (services/Applications) that uses Bonjour to advertise its existence (iChat is one guilty party).
     

Share This Page