External HD issues

Discussion in 'Mac Basics and Help' started by CrzyCanuck72, Jul 19, 2007.

  1. CrzyCanuck72 macrumors 6502a

    Joined:
    Jun 10, 2003
    #1
    My external HD (250 GB in a USB enclosure) won't mount on my MacBook. I downloaded and installed the 10.4.10 revision that is supposed to address USB issues, but it still won't mount, nor is it recognized by Disk Utility. I plugged it into a PC running XP, and it is recognized no problem. I tried the hint of using Pacifist to install certain USB components from 10.4.9, but it gave me 2 kernal panics, and scared the **** out of me, so I'm not doing that again.

    Any suggestions? I reformatted the drive on the XP computer to NFTS, hoping that it would be recognized on my Mac and I could reformat it with Disk Utility, but no dice.

    Thanks in advance
     
  2. Vader macrumors 65816

    Vader

    Joined:
    Oct 11, 2004
    Location:
    Saint Charles, MO
    #2
    Restart the macbook.
    If that doesn't help the issue, plug it in, unplug the usb drive with the power on and then plug it back in, see if that works.
    Those are things that worked for me with a firewire drive that wasn't mounting all the time on the macbook (mounted every time on my tower).
     
  3. ravenvii macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #3
    My first thought is that the external is dead, but if it works fine on the XP machine, then that's strange. Maybe you can try formatting it in FAT32 and see what happens? Since OS X can't really interact with NTFS much. (Read-only)
     

Share This Page