External HD not being recognised

Discussion in 'Mac Basics and Help' started by gadgetgirl85, Oct 25, 2007.

  1. gadgetgirl85 macrumors 68040

    gadgetgirl85

    Joined:
    Mar 24, 2006
    #1
    For some reason my external HD is not showing up when I plug it in yet if I plug it into my PC it does. Can somebody please help? :)
     
  2. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #2
    This seems to be happening a lot lately with 10.4.10. Here's a post with some info that may help: http://forums.macrumors.com/showthread.php?t=373840
     
  3. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    I think I stumbled onto the thread you linked also...very interesting. What an odd bug. I guess it doesn't impact everyone, and it only impacts certain classes of USB drives? (I haven't heard flash drive users complain about it, and that's the only kind of USB drive I have).
     
  4. gadgetgirl85 thread starter macrumors 68040

    gadgetgirl85

    Joined:
    Mar 24, 2006
    #4
    I wonder if theres something wrong with it. I tried plugging it into the PC and it 'recognises' it yet it won't let format it or do anything with it and doesn't show up in my computer either. I don't mind losing the files I just want to be able to use it on my mac again
     
  5. killerrobot macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #5
    Yeah, 10.4.10 knocked out support for my external. Messed around for months with it until I came across several other threads here such as this one http://forums.macrumors.com/showthread.php?t=333564.
    Yeah, same solution, just posted 3 months ago...

    10.4.10 has a few crazy bugs that are very random -it also jacked with my airport card stability on my MBP and that is yet to be fixed by anyone, yet others claim it fixed theirs. :confused:
     

Share This Page