External HD not detected

Discussion in 'OS X Mavericks (10.9)' started by GAUG3, Oct 17, 2015.

  1. GAUG3 macrumors member

    Joined:
    Jun 17, 2010
    #1
    My 2TB Western Digital My Book Studio's (Firewire) power went out. Even tried replacing the power adapter. Still won't power on. So we cracked open the enclosure and saw that it was SATA drive. I bought a docking station that will take the SATA drive and plugged it in with USB. The mid 2011 iMac does not see the drive in the About This MAc storage section. Disk Utility sees the docking station; however, it's not mounting. When I power it on it complains about "The disk you inserted was not readable by this computer". Initialize, Ignore, Eject are my options. Initilaize just opens disk utility. Puzzling because it worked before the power problem.

    Any ideas how to get Mac to see and mount it? i need to get data off of it.
     
  2. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #2
    Since the drive isn't mounting its possible it is mechanically damaged and If you absolutely have to get the data no matter the cost contacting data recovery company is best option.

    You could try data recovery software such as Data Rescue which might be able to recover data. If that doesn't work it's likely the drive is mechanically damaged and repairing it yourself is very tricky. Contacting data recovery company is safer option.
     
  3. GAUG3 thread starter macrumors member

    Joined:
    Jun 17, 2010
    #3
    Well poop.
     

Share This Page