External Hd not detected

Discussion in 'macOS' started by ichii, Oct 26, 2007.

  1. ichii macrumors 6502

    ichii

    Joined:
    Sep 20, 2006
    #1
    I have a external enclosure, that works fine before the leopard upgrade, I'm wondering if anyone else is having this problem or found a solution. I also don't like how I can't hide the hdd icon on the desktop. I tried the finder preference it just hide the mac partition but not the windows.
     
  2. ichii thread starter macrumors 6502

    ichii

    Joined:
    Sep 20, 2006
    #2
    anyone having this problem? I was planning to use it for time machine.
     
  3. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #3
    You don't actually state what your problem is but I have noticed that since upgrading to Leopard my Lacie 1TB Big Disk keeps removing itself. I dont know how to fix it but I have tried different wires and ports but it still randomly removes itself and I get a device removal warning. :mad:
     
  4. The Flan Bandit macrumors newbie

    Joined:
    Jul 21, 2007
    #4
    I'm having a similar problem. It seems to be an issue with firewire in general. My external iSight camera makes things crash and my old, old Lacie 60GB firewire drive only shows up sometimes and makes the finder and other programs hang weirdly.
     
  5. UNHtestr macrumors newbie

    Joined:
    Oct 27, 2007
    #5
    External HD not appearing

    I have a 500 gig USB lacie HD that does not appear when I plug it in. Disk Utility knows it is there, but the only thing it will let me do is erase it. Which I can't do since it is my only backup. I only had 9 gigs free when I went to upgrade, and Leopard wanted 11 for the install.
     
  6. r6girl Administrator/Editor

    r6girl

    Staff Member

    Joined:
    Sep 6, 2003
    Location:
    Massachusetts
    #6
    i'm having a similar problem. i cloned my hard drive under Tiger to prepare for a clean installation (erase & install) of leopard. now that i have leopard installed, i am having trouble transferring my music from my external drive. it will start to copy files, but will hang shortly after it starts, and leopard is completely unresponsive to anything. i have to do a forced shutdown to try anything else. of course, this is not good for my external drive.

    even after re-booting, the external drive doesn't always show up in finder - it's visible under system profiler, but not disk utility. wth?

    i had no problems whatsoever with this drive with Tiger, and i'm quite irritated that i can't complete the transfer of my files from it to Leopard right now. :mad: if anyone finds any solution this, information would be greatly appreciated!
     
  7. xtiandlr macrumors newbie

    Joined:
    Oct 29, 2007
    #7
    I am having the exact same problem with my external Maxtor one touch II. Everything was fine until the Leopard upgrade. It's very frustrating... help!
     
  8. freakpod macrumors newbie

    Joined:
    Jun 18, 2007
    Location:
    frankfurt
    #8
    Time machine fails to detect external HD

    I have the following situation , kindly help me out!:(

    - My external HD is transcend storejet 80gb with USB 2.0 (no firewire option).
    -When this external drive is connected to mac, it is mounted normally and i can access all the data just like any other flash drive.
    -once i open the time machine app, only hard drive it finds to back up is my windows partition and not the external disk.
    - then using disk utility i reformatted with Mac OS Extended format.
    -I am able to access the disk,but not make it a time machine backup drive.

    Is there any solution

    regards
     
  9. asaad macrumors member

    Joined:
    Oct 12, 2006
    #9
    similar issue, have an external HD, works fine with leopard shows up on the desktop and in finder I can access all files and browse through it however when I want to use it with Time Machine it doesn't show up on Time Machines initial set-up, any help for this?
     
  10. systemexiting macrumors newbie

    Joined:
    Oct 29, 2007
    #10
    Lacie 80g same problem

    My 80GB external Lacie won't display either. Works fine on other macs not running Leopard. Strange, yes?
     
  11. sirjec macrumors newbie

    Joined:
    Oct 28, 2007
    #11
    I'm having the same problem today, my external drive powers up when it's connected but it's not mounted on the desktop, Previously it was working fine.

    edit: FW800 didn't work, FW400 seems to half work...
     
  12. Hobbit6003 macrumors member

    Joined:
    Jun 8, 2007
    #12
    I'm having the same problem with my Western Digital MyBook 320Gb.

    I use FW400, and the disk dismounts itself twice today, when using Time Machine to do back up on it. It won't mount thereafter, even though I could see the disk using Disk Utility.

    I realised they happened when my MBP is inactive for a while and the display went to sleep.

    What I did was to unplug and then plug in the power and FW cable a few times, and then the HD mounted.
     
  13. Hobbit6003 macrumors member

    Joined:
    Jun 8, 2007
    #13
    Now, another problem i encountered today was this:

    This morning, I was demonstrating TM to a friend of mine, and got it to search for a movie I backed up. TM performed a search and found it, and I used quicklook to play it for my friend.

    Then I went for lunch and again left the MBP to idle for about 2 hours, during which TM performed a backup session.

    Then now, horror of horrors, that same movie was nowhere to be found!!! And so did the whole folder which contained many more movies I've backed up!

    At the same time, I found that the harddisk has gained about 10gb of memory space, which just correspond to the missing movie folder.

    Could I have accidentally deleted the folder away from the backup harddisk? I didn;t deliberately went into back up to delete anything.....

    Strange....all these anomalies occurred under the same circumstances: I let the machine idled for more than an hour, with the display put to sleep.
     
  14. AJsAWiz macrumors 68030

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #14
    Leopard Time Machine Problem

    I posted this in another thread:
    The bad news is, we have discovered a Leopard-related issue that may very well throw a monkey wrench into your Time Machine. Anyone trying to use Time Machine with a previously PC-formatted drive could be at risk. The good news is, there is an easy—albeit none-too-obvious—fix. Here's the dilly-o:

    After I upgraded my MacBook Pro to OS X Leopard, the first thing I did was grab a brand-new Maxtor USB drive and format it to Mac OS Extended (Journaled) using Disk Utility, just like I had countless times before. As soon as I erased the disk, Time Machine popped up as promised, and asked if it could use the disk for backup. I said yes, and was on my merry way. Only I wasn't.

    Time Machine ran for a bit, and then crapped out after about 10GB. I went into Disk Utility and saw that although the partition was formatted Mac OS Extended (Journaled), the volume itself still said FAT32. I clicked Erase to reformat the drive, and got the format failure error you see above.

    I tried this with FAT-formatted drives from Seagate, Iomega and HP as well. Each time I saw the same thing. I could reformat the partition to Mac OS Extended (Journaled), and Time Machine would recognize it. Get Info would say that it was formatted correctly. But Disk Utility showed that the volume was formatted for PC. Inevitably, if the Time Machine backup was greater than 10GB, there were problems. Worst of all, if I dared try to format the volume for Mac, I would get the dreaded error, and the disk would be temporarily unmountable.

    Not only did I vary drives, but I tested the problem on various systems too. I tried it booting from the Leopard DVD, with the same results. Ditto when I tried it using my wife's Leopard-upgraded MacBook Pro. (Yes, his n' hers MBPs. You can insert your "awwww" here.) The end result was that I couldn't break the FAT grip on these damn drives.

    I made some calls, I talked to some people, and eventually here was the solution: you wipe the hell out of the drive by creating new and different partitions. So, do not head to the Erase tab in Disk Utility to prep a PC-formatted drive for Time Machine. Instead:

    • Go to the Partition tab. Create two partitions. Under Options, select GUID Partition Table (what you would use to make a Mac OS boot disk) and click OK then Apply.

    • Once your partitions are in place, do it again, reverting back to just one partition, but still keeping the GUID Partition Table option. Click OK and Apply again, and at this point you should be cool.

    • To be safe, you can then go to Erase and set formatting for Mac OS Extended (Journaled), then format it once and for all. But when you get there, you will probably see that your volume is already formatted in the right way.

    UPDATE: Some people have gotten this to work without creating two partitions. If you like, try creating just a single partition, but using the GUID Partition Table option. This may be all it takes to break the chokehold.

    Using this method, I have gotten all of the disks to work just fine with Time Machine, and I don't anticipate any problems in the future.

    OK, I know, quite a bit of nerdiness, but I wanted to get out there and tell you about the problem I encountered, in case you are having the same troubles, or plan on getting there sooner or later. Also, this solution is actually a workaround of sorts. My hope is that Apple can update Disk Utility with a stronger form of disk erasing that doesn't require so many manual steps, but if I am missing something obvious, I'd love to hear it. Please share any troubles you've had, or any better solutions you've cooked up.

    Special thanks to Dorian and Ken!
     

Share This Page