external HD not formatable

Discussion in 'Mac Basics and Help' started by stonejo, Sep 21, 2011.

  1. stonejo macrumors newbie

    Joined:
    Sep 21, 2011
    #1
    I have a WD HD that was previously my time machine backup. When I decided to use it for something else, I went to reformat it and it said:

    POSIX reports: The operation could not be completed. Cannot allocate memory.

    I have tried every file type in disk utility.
    I have tried on a PC to go through DiskPart in the command prompt. and disk manager.

    Nothing has worked. Any possible ways around this would be appreciated.

    Thanks
     
  2. Quad5Ny, Sep 22, 2011
    Last edited: Sep 22, 2011

    Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
    #2
    In Windows open up a Admin command prompt, launch diskpart, select your drive, then type "clean"
    (cmd, run as admin, diskpart, list disk, select disk X, clean, exit)

    That will wipe all info on the drive. After thats done, plug it into OS X and see if Disk Utility works.


    EDIT: Be careful which drive you select. Because the clean command will wipe EVERYTHING off whichever drive you choose.
     
  3. stonejo thread starter macrumors newbie

    Joined:
    Sep 21, 2011
    #3
    I have tried that and it told me that the drive was not formatable and that the information may be lost.

    I also tried downloading the western digital software to zero the drive. also not working.

    m/b another suggestion? I feel it may be done with.
     

Share This Page