External HD Not recognized anymore...

Discussion in 'Mac Basics and Help' started by JurgenWigg, Jun 20, 2007.

  1. JurgenWigg macrumors 6502

    JurgenWigg

    Joined:
    May 20, 2006
    Location:
    Delaware
    #1
    I have a black macbook core duo (not c2d). After getting it I upgraded the harddrive from the stock 80 to a seagate 120, and then put the 80 in an external USB 2.0 enclosure and have been using it for a long time, for about the last 8 months or so. Recently, however, my computer stopped recognizing it. The HD doesn't show up in disc utility or on the desktop, finder, etc, but under system profiler, it shows that a USB storage device is hooked up. I know the connections are fine because of this, and that the HD is powered up and everything like that, but for whatever reason, no dice. How do i fix this?
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Does it work on another computer (Mac, preferably)?

    What file system is it formatted in?
     
  3. JurgenWigg thread starter macrumors 6502

    JurgenWigg

    Joined:
    May 20, 2006
    Location:
    Delaware
    #3
    I just tried it out on an iMac G5 running OS X 10.4 and it worked just fine. It's formatted as Mac OS Extended (Journaled).
     
  4. JurgenWigg thread starter macrumors 6502

    JurgenWigg

    Joined:
    May 20, 2006
    Location:
    Delaware
    #4
    Maybe another important note, i booted up from the OSX install disc and ran disc utility and it showed up there on my macbook. I checked repair disc and repair permissions on both and everything appears to be ok, with the exception that the harddrive is still not showing up on my macbook...

    Should i just put the files on that HD onto the iMac and then erase the HD? It doesn't seem like anything bad can happen since all the files are off of it, so I guess I'll try it and let you guys know how it goes.
     
  5. MikeTheC Guest

    MikeTheC

    Joined:
    Apr 26, 2004
    Location:
    Gallifrey -- Capitol City, Prydonian Sector
    #5
    It's either that or get a disk utility app (like Disk Warrior), run it, and see if it can fix the issue.

    However, if you can back up the data and nuke it, I'd suggest you take that route because, short of a genuine HW-based issue, this will solve all other possible contingencies.
     
  6. JurgenWigg thread starter macrumors 6502

    JurgenWigg

    Joined:
    May 20, 2006
    Location:
    Delaware
    #6
    After shouting many loud expletives and a general feeling of genuine frustration, my solution continues to elude me.

    I went into the disk start-up, where the HD is recognized (but not by the computer's disk utility for some unknown reason) and erased and repartitioned the external harddrive. Even so, the drive continues to be recognized by the G5 iMac, and continues to be ignored by my Macbook.

    I tested both of my USB ports, they work fine, and the drive is getting power, it's just not being accessed. So, it's not a problem with the now blank drive, or so it seems, nor the enclosure, nor the cable, nor the ports. What is going on here?!?
     
  7. JurgenWigg thread starter macrumors 6502

    JurgenWigg

    Joined:
    May 20, 2006
    Location:
    Delaware
    #7
    as per suggestion on the apple forums, i reset the SMC and PRAM to no avail. this is really getting annoying. the HD/enclosure/cable isn't broken because it works on the imac. the usb ports aren't broken because, well, everything else works on them. it's the combination of the USB hard drive and the software i guess. What do i do?
     
  8. asae macrumors newbie

    Joined:
    Jun 24, 2007
    #8
    I have exactly the same problem too, and...it started around the same date that your 1st post. I used, external usb hdd with mini usb enclosure formatted FAT32. Previously, using iMac intel, Tiger 10.4.9, it works like a breeze. But seems after upgrading to 10.4.10, it will not shown at all!! not even in the disk utility or drive genius.

    The drive still works fine in my pc - xp based. and have verified that there is no problem in my iMac usb ports. I have formatted, repartitioned again the usb hdd, still no luck.

    One funny thing, i used Paralel Desktop in my iMac - with XP installed, when i connect this usd hdd, it also works like a charm. so...seems that iMac physically recognized it, but the MacOs don't won't to show it??

    seems that it will lead me to accuse that the cause was my upgrade to 10.4.10 - which suppose to add more compatibility to usb but unfortunately it is not....

    I guess i have to reinstall my MacOSX to get the 10.4.9 back... :(
     
  9. JurgenWigg thread starter macrumors 6502

    JurgenWigg

    Joined:
    May 20, 2006
    Location:
    Delaware
    #9
    i'm wary of the 4.10 upgrade as well, but after upgrading the iMac G5 to 4.10, it still worked. Very weird...
     
  10. numlock macrumors 68000

    Joined:
    Mar 13, 2006
    #10
    im having the same problem after the upgrade. My usb2 external hard drive wont show up. Not on the desktop/finder nor in disk utility.

    I cant believe the only solution is a re-install. Surely apple will release a patch or something?

    EDIT:
    I restarted my imac and the external disk still didnt show up but suddenly my ipod shuffle had disappeared as well. So while just focusing on the shuffle for a second i "undocked" it and "docked" it again and then suddenly both the shuffle and my external disk showed up.
     
  11. heypeter macrumors newbie

    Joined:
    Jul 4, 2007
    #11
    me too! software update effed up external drive access

    My MBP was accessing the external drive without no problem until I updated the software. Any word on whether Mac's going to fix this bug?
    ahhhhh...the comfort of knowing I'm not the only one going nuts here.
     
  12. kikobarbada macrumors regular

    Joined:
    Jun 28, 2007
    #12
    This is a rebug from 10.4.10. Reinstall 10.4.9 or less or wait for .11 or leopard.
     

Share This Page