External HD not recognized on new macbook pro

Discussion in 'Mac Basics and Help' started by lwmcanada, Jul 24, 2007.

  1. lwmcanada macrumors newbie

    Joined:
    Jan 19, 2006
    #1
    I recently bought a 2.2 Ghz Macbook Pro, and one of my external hard drives isnt recognized, its a USB powered Western Digital Passport

    http://www.westerndigital.com/en/products/Products.asp?DriveID=317

    (Same as this one, but only 120GB)

    It runs fine on my old iBook G4, but when plugged into my new MBP, it doesnt run at all. Has no recollection of the hard drive at all. I've tried reformatting it, still nothing.

    Anyone have any ideas? Any opinions are much appreciated.

    Thanks
     
  2. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #2
    Do you have an AC adaptor for the drive? If not, get one and see if it is recognized when it's not trying to draw bus power.
     
  3. CrzyCanuck72 macrumors 6502a

    Joined:
    Jun 10, 2003
    #3
    I had the problem of my USB external HD not being recognized either... it wouldn't mount, nor was it even recognized by Disk Utility. I did some research, and realized that it had stopped working after I updated to OS 10.4.10. It's a well-documented issue with the 10.4.10 update... I don't know if this is the cause of your problem, here's what I did to fix it.

    don't hold me responsible if anything effs up.. but it worked for me. I wish I had done it before reformatting my HD on a PC, though :(
     
  4. lwmcanada thread starter macrumors newbie

    Joined:
    Jan 19, 2006
    #4
    Weird

    OK, now i have some weirder news.

    It works fine on the right USB port, which i never tried, stupid me. BUT doesnt work on the USB port on the left:confused: uhhh what da.???

    Is this a hardware problem or what? because everything else I have plugged into the left works fine.
     
  5. killerrobot macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #5
    @CrzyCanuck72

    Awesome. Finally found a post that works for this. Thanks!!!:)

    @OP
    If it works on one and not the other then it does sound like a hardware issue to me... good luck.
     
  6. esmuz macrumors newbie

    Joined:
    Aug 9, 2007
    #6
    I have 10.4.8 installed in my MBP with the same problem.. should I upgrade to 10.4.9 and then do what CrzyCanuck72 says?

    I hope this issue gets solved in Leopard it´s a shame.
     
  7. killerrobot macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #7
    Not sure what to tell you about that. I never lost support of my external until 10.4.10. I would double check that another computer can still read/mount it,
    and upgrading to 10.4.9 shouldn't make the problem any worse.
     
  8. arezendes macrumors newbie

    Joined:
    Jan 7, 2009
    #8
    Don't install applejack and extract any files from an earlier OS. You'll do more damage than good.

    Check to see if any other USB device works in your USB ports. If so, it's not a USB issue, it's a hardware issue. Check your external drive casing to ensure the enclosure is properly connected to the drive (mine wasn't). Save yourself the headache of having to reinstall your system software by NOT following the the instructions above. They don't work. In fact, they make your mouse and keyboard freeze up! Ask him why he doesn't want to be held responsible for the results? He knows....It's a BS solution! If you can't get it to work take the drive and your laptop to a local Mac Genius at the apple store. They'll hook you up.
     
  9. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #9
    Not that it particularly matters, but you do realize you are digging up a post from well over a year ago right? I am sure most people that were involved have moved on to Leopard now making this Tiger thread pretty moot.

    The reason I ask is that there were several points in the Tiger update cycle that the IO kexts were certainly the cause of some people' USB problems and reinstalling those from the previous version using Pacifist was a proven and workable fix- not a BS solution by any stretch of the imagination. Doing the procedure right (when warranted) did not cause mouse or keyboard freezes.
     
  10. lostinTX macrumors newbie

    Joined:
    Jun 20, 2009
    Location:
    Houston, TX
    #10
    USB external HD not recognized by OS X 4.11

    Well I had the same problem with OS X 4.11 not seeing an external USB hard drive. I was trying to clone my powerbook HD to a new USB hard drive. So I had to buy a self powered USB hub (like Belkin) which has its own AC adaptor. This worked and my powerbook had no trouble seeing the USB drive through the hub.

    As for that crap posted by CrzyCanuck72, I agree that is BS and I wouldn't do that to my powerbook; if you have Tiger you should be running 4.11 anyway.
     

Share This Page