External HD not showing up, even in Disk Utility

Discussion in 'Mac Basics and Help' started by widen88, Aug 15, 2009.

  1. widen88 macrumors newbie

    Joined:
    Aug 15, 2009
    #1
    I've been having trouble with my Western Digital 160GB HD, its one of the MyPassport ones or what not. It used to work like a charm and had for a while but a couple of days ago it just stopped being able to be read or even recognized on Macs. I tried this laptop and another macbook pro and both would not show the HD on the desktop or even Disk Utility. When I open the Disk Utility when the ExHD is plugged in, I just get that loading circle and it will just do that indefinitely. Same thing with System Profiler as well.

    I don't believe I damaged it in anyway, I hear no clicking and it seems to "boot" smoothly when it's plugged in, so would this mean its a corruption issue? I have been plugging this in to different Macs recently, (3 total) and one of which runs Leopard while the other two run Tiger. Would that cause the issue? (the reason I ask is that this all started after I had plugged it into the different OS.) I haven't tried to plug it into a PC yet, i'm going to do that today but I had tried doing the CMD + Option+ P + R reset till the second beep and I also did a hard reset by unplugging everything and waiting a bit then holding the start button down until it beeps. Any help would be greatly appreciated since the info on this drive pretty much holds all the backup to this laptop, (which blows and got raped by the known heating problems due to lack of quality manufacturing) which won't be lasting much longer seeing as I can't even run a movie without it overheating (even with SMC maxing fan speed + a cooling pad) and freezing the screen. :eek:



    Another update to this I just noticed is that when it is plugged in and I run System Profiler, the USB tab won't load. If I unplug ExHD, the tab shows up and even shows the external under the USB High Speed Bus tab, but it shows no Volumes
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    The problem is either with the enclosure, the drive or the cable. Even if the drive were corrupted it would show up in Disk Utility, there would just be no volume listed underneath it.

    First I would try buying a new cable. If that doesn't solve the problem, you have two options. If there's data on there that you can't lose, you could try purchasing a new 2.5" enclosure and plugging the drive in there. If that doesn't work, or if you don't mind losing the contents of the drive, give WD a call. Their drives come with either 3- or 5-year warranties (can't remember which offhand) so they should replace it for you.
     
  3. widen88 thread starter macrumors newbie

    Joined:
    Aug 15, 2009
    #3


    to provide an update, when I plugged it into a PC, it worked fine. Furthermore, when I plugged it back into a Mac, it started to work. So, I guess it fixed itself by going into a new OS or something!
     

Share This Page