External HD only occasionally showing up on mac

Discussion in 'MacBook Pro' started by Drodrey, Mar 24, 2016.

  1. Drodrey macrumors newbie

    Joined:
    Jan 9, 2010
    #1
    Hiya. I have a 2014 MacBook Pro. I also have a 2TB Western Digital MyPassport external HD that's about 12 months old. This HD has no power source, I simply plug it directly into my Mac via the USB port.

    Recently, my MacBook has only sporadically read my external. I plug it in. The light comes on the HD, it makes the normal "thinking" sound, as if it is being read, but nada on the Mac. Not in Finder, not in Disk Utility. I've ran a couple of terminal commands to check whether it's been marked as "hidden" and it's literally as if there's no HD plugged in. I will leave it for hours and nothing.

    I don't really have any rhyme or reason for when it does work. Usually once it starts working, it's pretty good for a few goes. I find if I remove the disk without safely ejecting there's little to no chance it will work for a while afterwards. Often, when it finally does boot, it will eject itself quite quickly and come up with the "you have unsafely removed hardware", as if I've pulled the plug, when I haven't touched it.

    Also, when I reset the entire MacBook, with the HD plugged in, usually my Mac won't boot. It will sit on a black screen, and will only start up once I unplug the external. This makes me think it's not the cord.

    I'm currently travelling, so don't easily have access to other Mac's to see whether it's my computer or the HD.

    Anyone ran across anything like this before? Would appreciate any help/advice I can get!
     
  2. Dadioh macrumors 65816

    Dadioh

    Joined:
    Feb 3, 2010
    Location:
    Canada Eh?
    #2
    Your external drive may be asking for more current than your USB port can provide. It would thus not get enough power to operate correctly. Older drives were less power efficient and sometimes came with USB cables with a "Y" connection to plug into the other USB port to get enough current for the drive.
     
  3. Drodrey thread starter macrumors newbie

    Joined:
    Jan 9, 2010
    #3
    Excellent thank you, I'll try and see whether I can find a "Y" cable somewhere to see whether that solves the issue.
     
  4. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #4
    - I doubt very much that's your problem. You have a newer Mac and from what I can see the hard drive isn't very old either. It should work with its included cable.

    Tried testing it with another machine just to see?

    My money's on a defective WD unit. RMA it with WD or your retailer.
     
  5. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #5
    OP wrote:
    "This HD has no power source, I simply plug it directly into my Mac via the USB port."

    On the external case, is there a -port- for an external power source?
    Even if one may not have been included?

    The MacBook may not be putting out enough "bus power" (through one USB port) to get the external drive "up and running" consistently.

    As suggested above, a "Y-cable" might work. This "gathers" the bus power from -2- ports, combines it, and -might- provide the power you need to get the external mounted and running.

    Another thought:
    You might try a USB -POWERED- hub (which comes with its own power supply).
    Then bus power won't be an issue.

    Something to try:
    You'll need another Mac -- preferably a desktop Mac like an iMac.
    Plug your drive into the desktop Mac and see what happens...
     
  6. Drodrey thread starter macrumors newbie

    Joined:
    Jan 9, 2010
    #6
    This is months old, but thought I'd post a reply anyway. I finally got around to buying a "Y-cable", and it worked a charm. The last month or so I haven't been able to get my HD to show up at all, but now with the double cable, it shows up in seconds.

    Big thanks for the idea guys, best £4 I've spent in a while!
     
  7. BrettApple macrumors 65816

    BrettApple

    Joined:
    Apr 3, 2010
    Location:
    Heart of the midwest
    #7
    Hmm, good to hear! I have a 4TB My Book attached to my rMBP and every other month or so I'll have to power cycle the external drive or it just flat doesn't show up on the Mac. It'll spin up and blink but nothing from the OS X side will see it. Once I unplug it from power and replug it'll show up immediately. Simply disconnecting the USB cable won't do it. Been that way since Yosemite if I recall correctly Mavericks never had this issue. Not a big deal though and different from your issue since it's a powered drive.

    I do find those 2.5" drives that are larger in size take more power than the slimmer 9.5mm drives if thats the case here and do need a Y cable. While others are fine being bus powered. Strange stuff.
     

Share This Page