External HD Problem, Help please

Discussion in 'MacBook Pro' started by hardhead89, Dec 7, 2006.

  1. hardhead89 macrumors member

    Oct 26, 2006
    Maryland, USA
    I have an external HD that I used to use on my PC. I then got my MBP C2D and hooked it up to here. it worked fine for a few days but now all of the sudden I only have read privilages on it. i cant seem to write to it. i called apple and they told me to call western digital, i called WD and they told me they couldnt help. i ran the disk utility and i cant even get first aid to work on it. does anyone have any ideas about how to fx this. id really appreciate any help.
    I am running OS x btw.
  2. WildCowboy Administrator/Editor


    Staff Member

    Jan 20, 2005
    How is it formatted?

    The standard Windows format is NTFS, which OS X can read but not write to. You would have to reformat it in FAT32 in order to use it with both Windows and OS X. Or if you just want to use it on Macs, you can format it in HFS+.

Share This Page