External HD randomly ejecting

Discussion in 'Mac Accessories' started by downingp, Apr 4, 2010.

  1. downingp macrumors 6502a

    Joined:
    Jun 26, 2006
    #1
    I have a 1 TB WD external hard drive I store my music and videos on. I have noticed that the hard drive will randomly eject itself causing me to have to turn the external hard drive off and back on for the iMac to mount it again. I have a new iMac i5 and had a 24" 2.4 GHz iMac previously. I was using the firewire port on my previous iMac before and would occasionally experience this problem. However, having to use the USB port on the new iMac it is occurring on a daily basis. I have tried different ports on the back of the iMac thinking it was a USB problem, but that didn't seem to help. I have run disk utility and it says the drive is in good health.

    Any ideas? Thanks.
     
  2. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #2
    If this this is a WD Essential or Studio drive, I used to have the same issues. I switched to a different brand and no longer had the issues, so I concluded that it was a problem with the drive enclosures themselves. I had tried using conditioned power, a UPS… nothing worked, so now I stay away from the WD 3.5" drives.
     
  3. ThirteenXIII macrumors 6502a

    Joined:
    Mar 8, 2008
    #3
    its just the firmware of their enclosures & drives.
    OEM Western Digitals are exceptional compared to most other manufactured drives.
    It depends on the chipset, and preinstalled firmware/software WD uses with their drives to make them dependent on the enclosure which causes errors with different OS'
     
  4. downingp thread starter macrumors 6502a

    Joined:
    Jun 26, 2006
    #4
    Is there a way to fix the issue or should I try and take the hard drive back and get a new one?
     
  5. downingp thread starter macrumors 6502a

    Joined:
    Jun 26, 2006
    #5
    Any other recommendations? Is this a known issue? Should I take the hard drive back?
     
  6. NOTORIOUS187 macrumors member

    Joined:
    Dec 31, 2009
    #6
    I recently began having a similar issue with my 500GB WD external. I was in the middle of watching a movie when it randomly ejected, and when I tried to remount the drive the computer would not recognize it. I plugged it into other computers (two PCs) and one recognized it for a minute or two and then stopped, while the other did not recognize it at all. (By recognize I mean allow me to access the files on it; sometimes the computer would see a drive but was unable to determine what kind of drive it was and would not let me browse the files).

    I plugged it in a few hours later last night and was able to see my files again, but in the middle of copying a movie from it to a USB drive it ejected again and the computer would not recognize it.

    I haven't had any problems with this drive since I purchased it in December 2007. Until recently, I had been using the FW400 port, but since my new MBP only has USB I had to switch.

    Not really sure what the problem is or what to do.
     
  7. punchygoes macrumors newbie

    Joined:
    Oct 15, 2010
    Location:
    NZ
    #7
    any success solving the issue?

    Hi, I am ripping my hair out trying to figure out a fix for this problem, notorious, did you ever find a solution to the self-ejecting external?
     
  8. downingp thread starter macrumors 6502a

    Joined:
    Jun 26, 2006
    #8
    I updated the firmware on the external hard drive through the western digital website and have had no problems.
     
  9. punchygoes macrumors newbie

    Joined:
    Oct 15, 2010
    Location:
    NZ
    #9
    That didn't help me. There is nothing new for me to update on mine. Notorious if you could let me know if you managed to fix yours and how I would REALLY appreciate it. Thanks.
     
  10. Corndog5595 macrumors 65816

    Joined:
    Jul 16, 2010
    #10
    Is it giving the "You have to unmount first…" message when this happens. You probably have to disable putting HDD's to sleep.

    System Preferences > Energy Saver
    Uncheck: > Put the hard disk(s) to sleep when possible
     

Share This Page